I want to find out about the Windows XP "shares" on my wife's windows machine by browsing from my Linux machine using Samba. I am relatively clueless about both windows and samba. I tried a basic operation from the command line and got this error:

: nr@homedog 8088 ; smbclient -L sapphire
timeout connecting to
timeout connecting to
Connection to sapphire failed (Error NT_STATUS_ACCESS_DENIED)

I've Googled this error message and have determined that a lot of people have similar problems, but I can't find a workaround. I suspect my wife has to grant some sort of access or permission on the Windows side. Any suggestions?


OK, it turns out the problem was with the Samba smb.conf configuration file. The NetBIOS name of my wife's machine happened to coincide with the hostname of a machine on a network searched in my /etc/resolv.conf. For some reason Samba requests and Nautilus were going to this machine instead of to the machine on the local net.

I fixed the problem by telling /etc/resolv.conf not to search the offending domain. At this point smbclient -L started working and so did remote mounts from Nautilus.

| improve this answer | |

Currently there's a problem with accessing Windows 7 shares: they've changes something in the protocol, and Linux Samba is no more compatible. I guess they've released a patch for XP that makes it incompatible too: this was made to make Win7 shares accessible to XP and vice versa.

These are only guesses based on logical conclusions. If possible, try running an outdated XP on a virtual machine and list its shares: if this works, I'm right :)

Also I've read that Samba developers are currently negotiating with M$ about the new protocol, and soon we'll see a patch that makes Samba compatible again.

P.S. Learn how to click "accept this solution" tick, or you'll never get any answers.

Cheers! :)

| improve this answer | |
  • I won't accept a solution unless it works :-) – Norman Ramsey Nov 23 '09 at 4:57
  • +1 for useful information, and we'll hang on to our carefully obsolete version of XP, but this wasn't the problem. See my answer below. – Norman Ramsey Nov 23 '09 at 5:15
  • :)) I don't ask to! Just walk through your recent questions to increase accept rate: 25% looks like "he asks and disappears" :) BTW yesterday I tried to print from Windows Server 2008 (R1) to samba-shared printer with no success. 2008 is based on Vista, Seven - too. Thank God they've added IPP printing instead! I believe the only solution for now is to use FTP :( – kolypto Nov 24 '09 at 9:09

The easiest way to learn more about it is to:

  1. Ask questions like you have done
  2. Read the man page for the command you are running.

When reading the smbclient man page, you will see that you can provide both a username and password. This can be done by: smbclient -L hostname -U username

You will then be prompted for a password to enter.

As Tync said, m$ may have introduced some patches that effect the compatibility between windows and samba.

Hope this helps,


| improve this answer | |
  • It doesn't work. My smb.conf seems to be doing a DNS lookup on sapphire, then timing out. – Norman Ramsey Nov 23 '09 at 5:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.