3

I'm using Windows XP Professional Version 2002 Service Pack 3. I have issues with DNS (after affected by some malware). I cannot ping the sites, but I can browse using a web browser. I have tried the below methods:

  1. net stop dnscache and net start dnscache
  2. netsh winsock reset all
  3. Changed static IP to dynamic and vice versa.

But nothing worked for me.

I know this is related with DNS, but I can ping DNS server. Where should I check next ?

Edit: Please see the result for ipconfig /all and nslookup google.com enter image description here

  • If you know you were affected by some malware, the only sensible solution is to completely wipe out your system and install it back from scratch with a known reliable source. Otherwise you may be chasing leftovers from the malware for a longtime. – Patrick Mevzek Sep 10 '17 at 15:32
3
  1. Check your DNS server settings by using ipconfig /all
  2. Check your hosts file (located in X:\WINDOWS\system32\drivers\etc). It should be reseted if it contains some non-default records.
  3. Check what nslookup google.com will show.
  4. Check your browser proxy settings and/or proxy-like addons. If you can't resolve NS record via ping, but can use your browser it might be resolved through proxy.
  5. Check your firewall (bundled or external if you have any) settings. It might block ping utility or everything except your browser.
  6. Check your antivirus software if you have it to block some network/software.
| improve this answer | |
  • You might be right in the point 2 and 6. It happened to me after installing an antivirus software. Let me check and update you. And right now, I use hosts file to resolve the DNS names, reset mean should I delete all these entries ? – Rauf Sep 7 '17 at 7:03
  • I disabled firewall of antivirus, still, I am getting the same issue. – Rauf Sep 7 '17 at 7:46
  • @Rauf you can backup your hosts file and get a clean one (you can search for it) just to make sure if the problem is still there. If this won't help, please post your output from the commands mentioned in 1 and 3. No one will be able to help you without knowing your configuration details. Also try to change DNS server to something else. Like 8.8.8.8 (this is Google free DNS). Even if you can ping your DNS doesn't means the DNS services (UDP port 53) are working. That is why I've asked for nslookup - it responds if there was an error connecting to your DNS server. – NStorm Sep 7 '17 at 8:04
  • @Rauf your DNS server and resolution are working, as nslookup was able to look up the IP. What does the ping says? If it's timed out, probably you have your ICMP packets blocked somewhere. – NStorm Sep 7 '17 at 10:47
  • 1
    @NStorm You are a god among men. For YEARS I've been completely unable to sign into my Jetbrains account from any program on my computer. I couldn't visit their website, etc. I thought it was my network, my firewall, my browser, my router settings, could have been anything. I did DNS flushes, the works. It was the hosts file. Look what I found inside my hosts file. It was from when I bootlegged a copy years ago. Thank you again. – Hatefiend Aug 9 '19 at 5:24

Not the answer you're looking for? Browse other questions tagged or ask your own question.