0

I am exactly in this situation:

Windows 2012 remote access can't connect

The RDS role was installed erroneously, and the grace period to decide the licensing mode was left to expire; when I tried to connect, I was greeted with (the Italian localized version of) this message:

Remote Desktop Connection - The remote session was disconnected because there are no Remote Desktop License Servers available to provide a licence. Please contact the server administrator.

Since we use RDP just for remote administration, after reading around that two administrative connections are "built in" if the RDS role is not installed, I removed the RDS role and rebooted; as a result, it was impossible to connect - the 3389 port wasn't even open.

Then, I found that the Remote Desktop setting in the System properties dialog (the same that you would use to enable RDP on a non-server machine) wasn't enabled; I enabled it, and now when connecting I get this message:

Errore licenza - Prego contattare l'amministratore

(in English that would be "License error - Please contact the administrator")

which is in fact different from what appeared before (when the RDS role was enabled), but it still isn't letting me in. I restarted the various RDP-related services to no avail.

This appears exactly the same both when connecting with mstsc from a Windows machine (with and without /admin) and rdesktop from a Linux machine (with and without -0, which AFAIK now shouldn't even have an effect on Windows >2008 Server).

Is this going to go away after yet another reboot or I have to perform some other magic to convince this thing to let me in? No, rebooting didn't fix anything. Suggestions?

0

Delete the following registry key:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSLicensing

After deletion also if it still gives the error, try to Right-Click on the Remote Desktop Connection icon and select “Run as Administrator“ and try to rdp to your server.

Source : https://community.spiceworks.com/how_to/40598-fix-remote-session-was-disconnected-because-there-are-no-remote-desktop-client-access-licenses

  • This doesn't make any sense, it talks about doing stuff on the client machine; here the server kicks out any client on any machine, including Linux clients that work just fine when connecting to "regular" RDP (no RDS) machines. Also, even the error message is different. – Matteo Italia Sep 15 '17 at 12:57
0

After some extra reboot/update install the problem fixed itself. No idea what may have fixed it, let's hope it keeps working.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.