0

Just rebuilt my WSUS Server 2012 R2 x64 from a VLSC disc. Added drivers and then joined the server to the domain. I then tried to install WSUS. I was able to add the feature. Then during post install I get the following error:

2017-09-08 14:25:20  CreateDefaultSubscription failed. Exception: System.InvalidOperationException: Client found response content type of 'text/html; charset=utf-8', but expected 'text/xml'.
CS0016: Complier error: C:\Windows\Microsoft .NET\Framework64\Temporary ASP.NET Files\apiremoting30\asdv832.dll -- 503 Access denied

Is there something in my GPO that is preventing an account from accessing this directory? This directory has not been specified anywhere in my GPOs but it immediately failed when on my domain. When the server is off the network it installs WSUS without a problem. How can I check?

0

I'm going to take an off the wall guess here based on some research I did. I wonder if this is the first and only time you tried installing WSUS on this server?

Once the components in IIS have been built, you may have conflicts if you have tried to reinstall WSUS multiple times or you used a default installation of IIS. Either way, this is what I would try.

First, try to remove the static and dynamic compression module on IIS and reinstall WSUS.

  • On the taskbar, click Server Manager.
  • In Server Manager, click the Manage menu, and then click Remove Roles and Features.
  • In the Remove Roles and Features wizard, click Next. Select the destination server and click Next.
  • On the Server Roles page, un-select Windows Server Update Services and expand Web Server (IIS), expand Web Server, expand Performance, and then un-select Static Content Compression and/or Dynamic Content Compression. Click Next.
  • On the Remove features page, click Next.
  • On the Confirm removal selections page, click Remove.
  • On the Results page, click Close.

Now, re-add the WSUS role and see if it will complete. Do not allow it to re-add the static or dynamic compression modules.

If it still fails, try to completely remove the Web Server (IIS) and WSUS roles, delete the C:\Inetpub folder and re-add the WSUS role allowing it to add the additional components necessary for the Web Server (IIS) role automatically.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.