0

my apache error.log has a lot of segfault errors:

[core:notice] [pid 16753] AH00052: child pid 4861 exit signal Segmentation fault (11)

And also some glibc detected errors every 10 hours or so:

*** glibc detected *** /usr/sbin/httpd: malloc(): corrupted unsorted chunks 2: 0x00007fcfcde5fd80 ***
======= Backtrace: =========
/lib64/libc.so.6(+0x75dee)[0x7fcfcb7f1dee]
/lib64/libc.so.6(+0x7a4b8)[0x7fcfcb7f64b8]
/lib64/libc.so.6(__libc_malloc+0x5c)[0x7fcfcb7f6aac]
/opt/cpanel/ea-php56/root/usr/lib64/php/modules/ioncube_loader_lin_5.6.so(+0x104f5f)[0x7fcfc2a14f5f]
/opt/cpanel/ea-php56/root/usr/lib64/php/modules/ioncube_loader_lin_5.6.so(+0xd6506)[0x7fcfc29e6506]
/opt/cpanel/ea-php56/root/usr/lib64/php/modules/ioncube_loader_lin_5.6.so(+0xd8352)[0x7fcfc29e8352]
/opt/cpanel/ea-php56/root/usr/lib64/php/modules/ioncube_loader_lin_5.6.so(+0x74e82)[0x7fcfc2984e82]
/opt/cpanel/ea-php56/root/usr/lib64/apache2/modules/libphp5.so(compile_filename+0xae)[0x7fcfc4faa6de]
/opt/cpanel/ea-php56/root/usr/lib64/php/modules/ioncube_loader_lin_5.6.so(+0x72e76)[0x7fcfc2982e76]
/opt/cpanel/ea-php56/root/usr/lib64/php/modules/ioncube_loader_lin_5.6.so(+0x71179)[0x7fcfc2981179]
/opt/cpanel/ea-php56/root/usr/lib64/php/modules/ioncube_loader_lin_5.6.so(+0x714ff)[0x7fcfc29814ff]
/opt/cpanel/ea-php56/root/usr/lib64/apache2/modules/libphp5.so(zend_call_function+0x9b0)[0x7fcfc4fcd800]
/opt/cpanel/ea-php56/root/usr/lib64/apache2/modules/libphp5.so(zend_call_method+0x1c7)[0x7fcfc4ff3a07]
/opt/cpanel/ea-php56/root/usr/lib64/apache2/modules/libphp5.so(+0x18c116)[0x7fcfc4ee4116]
/opt/cpanel/ea-php56/root/usr/lib64/apache2/modules/libphp5.so(zend_call_function+0x929)[0x7fcfc4fcd779]
/opt/cpanel/ea-php56/root/usr/lib64/apache2/modules/libphp5.so(zend_lookup_class_ex+0x255)[0x7fcfc4fcdd25]
/opt/cpanel/ea-php56/root/usr/lib64/php/modules/ioncube_loader_lin_5.6.so(+0x99b95)[0x7fcfc29a9b95]
/opt/cpanel/ea-php56/root/usr/lib64/php/modules/ioncube_loader_lin_5.6.so(+0x71179)[0x7fcfc2981179]
/opt/cpanel/ea-php56/root/usr/lib64/php/modules/ioncube_loader_lin_5.6.so(+0x714ff)[0x7fcfc29814ff]
/opt/cpanel/ea-php56/root/usr/lib64/apache2/modules/libphp5.so(zend_execute_scripts+0x18c)[0x7fcfc4fda53c]
/opt/cpanel/ea-php56/root/usr/lib64/apache2/modules/libphp5.so(php_execute_script+0x2aa)[0x7fcfc4f7839a]
/opt/cpanel/ea-php56/root/usr/lib64/apache2/modules/libphp5.so(+0x329c45)[0x7fcfc5081c45]
/usr/sbin/httpd(ap_run_handler+0x40)[0x7fcfcd012b90]
/usr/sbin/httpd(ap_invoke_handler+0xce)[0x7fcfcd01704e]
/usr/sbin/httpd(ap_process_async_request+0x3fa)[0x7fcfcd02b7ea]
/usr/sbin/httpd(ap_process_request+0x1f)[0x7fcfcd02b94f]
/usr/sbin/httpd(+0x5c7c5)[0x7fcfcd0277c5]
/usr/sbin/httpd(ap_run_process_connection+0x40)[0x7fcfcd01e250]
/etc/apache2/modules/mod_mpm_prefork.so(+0x3ae4)[0x7fcfcaf6cae4]
/etc/apache2/modules/mod_mpm_prefork.so(+0x3d1e)[0x7fcfcaf6cd1e]
/etc/apache2/modules/mod_mpm_prefork.so(+0x4775)[0x7fcfcaf6d775]
/usr/sbin/httpd(ap_run_mpm+0x4e)[0x7fcfccff3cce]
/usr/sbin/httpd(main+0xbc1)[0x7fcfccfecfc1]
/lib64/libc.so.6(__libc_start_main+0xfd)[0x7fcfcb79ad1d]
/usr/sbin/httpd(+0x205c9)[0x7fcfccfeb5c9]

Apache version:

Server version: Apache/2.4.27 (cPanel)

php version:

ea-php-cli Copyright 2017 cPanel, Inc.
PHP 5.6.31 (cli) (built: Aug 17 2017 01:08:43)
Copyright (c) 1997-2016 The PHP Group
Zend Engine v2.6.0, Copyright (c) 1998-2016 Zend Technologies
    with the ionCube PHP Loader (enabled) + Intrusion Protection from ioncube24.com (unconfigured) v6.1.0 (), Copyright (c) 2002-2017, by ionCube Ltd.
    with Zend Guard Loader v3.3, Copyright (c) 1998-2014, by Zend Technologies
    with Zend OPcache v7.0.4-dev, Copyright (c) 1999-2015, by Zend Technologies

I'm running DSO handler(CGI) with prefork, and i have the following apache modules:

Loaded Modules:
 core_module (static)
 so_module (static)
 http_module (static)
 mpm_prefork_module (shared)
 cgi_module (shared)
 access_compat_module (shared)
 actions_module (shared)
 alias_module (shared)
 asis_module (shared)
 auth_basic_module (shared)
 authn_core_module (shared)
 authn_file_module (shared)
 authz_core_module (shared)
 authz_groupfile_module (shared)
 authz_host_module (shared)
 authz_user_module (shared)
 autoindex_module (shared)
 deflate_module (shared)
 dir_module (shared)
 env_module (shared)
 expires_module (shared)
 filter_module (shared)
 headers_module (shared)
 imagemap_module (shared)
 include_module (shared)
 log_config_module (shared)
 logio_module (shared)
 mime_module (shared)
 negotiation_module (shared)
 proxy_module (shared)
 proxy_fcgi_module (shared)
 proxy_http_module (shared)
 proxy_wstunnel_module (shared)
 rewrite_module (shared)
 setenvif_module (shared)
 slotmem_shm_module (shared)
 socache_dbm_module (shared)
 socache_shmcb_module (shared)
 status_module (shared)
 suexec_module (shared)
 unique_id_module (shared)
 unixd_module (shared)
 userdir_module (shared)
 ssl_module (shared)
 bwlimited_module (shared)
 auth_token_module (shared)
 flvx_module (shared)
 php5_module (shared)
 h264_streaming_module (shared)

What can cause my errors?

0

It looks like the fault is occurring in ioncube. Having said that, you have a huge and diverse number of modules loaded on your webserver which is not exactly a recipe for stability. You are also running 2 decoders on the same instance. Then for some reason you've got cpanel in the mix too (which makes your question off topic here).

If you really do need all these modules and both encoders then you should start by splitting the applications across seperate instances.

  • Thank you, it was indeed ioncube, now i will look into the matter of why is it happening. How did you know that ioncube was causing it? – Marcus Sep 10 '17 at 10:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.