0

I always ignored this problem because I was able to restart the system, but this time a reboot is not possible.

For some applications I edit the configs partially in /etc/default/* (at least on debian), like openvpn or snmp.

This time I want to change the start parameters from snmp, so I edit the file /etc/default/snmpd but what I change there does not apply when I restart snmpd, only when I reboot the whole system.

Is there any workaround for this problem?

4
  • 2
    Putting your OS version might be critical here, because starting from Debian 8.0 init system has been changed to systemd by default. And how do you restart your service exactly (command)?
    – NStorm
    Sep 11, 2017 at 13:35
  • What the particular option you are changing in /etc/default/snmpd which requires system reboot?
    – Khaled
    Sep 11, 2017 at 13:53
  • Debian 9.1, I restart with service snmpd restart OR /etc/init.d/snmpd restart OR systemctl restart snmpd.service @Khaled I edit the parameter "SNMPDOPTS=" to change verbosity level
    – lemon
    Sep 11, 2017 at 13:54
  • And yes the new init system seems to be the problem, on debian 8 it works just fine.
    – lemon
    Sep 11, 2017 at 14:06

1 Answer 1

0

/lib/systemd/system/snmpd.service replaced /etc/default/snmpd in debian 9 because of systemd

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.