I'm having a shocking time trying to install SQL Server 2008 on 64-bit Windows 7. When I run setup.exe, I get the following error message:

Microsoft .NET Framework 3.5 installation has failed.

SQL Server 2008 Setup requires .NET Framework 3.5 to be installed

Things I've tried:

  • I've checked and double checked. I do have .NET Framework 3.5 installed, with SP1
  • I've read about a missing Windows Installer 4.5 installation producing the same error. Win7 comes with Windows Installer 5, which hopefully satisfies this requirement, as I've tried to install 4.5 and it won't let me
  • Burning the ISO to DVD and installing from there.
  • Installing on an XP machine using the same ISO. This works, so the ISO must be fine.
  • Considering SQL Server 2005, but it really needs to be 2008 for the project.
  • Update Creating a slipstream version gives the same error
  • Update I could install SQL Server Express, and then SP1, but couldn't upgrade to Enterprise.

If you've come across this issue, or know how to fix it, I'd love to know.

  • 1
    Irony is, I was able to install it with just slight problems, but since it was easy to google it, I didn't even care. Now I have to install it again, and I am dead stuck :-( – greenoldman Jun 9 '11 at 18:52

Best answer: Install SQL Server 2008 R2.

I tried all of these solutions and they all failed. R2 installed perfectly, the first time.

  • Normally I dislike such answers, but unfortunately in this case you are right. – greenoldman Jun 10 '11 at 11:58

Maybe the problem is that the installation is only supported for SQL Server 2008 SP1 on Windows 7

Windows 7 64-bit x64 Professional (1,3)

1) Management Tools are supported in WOW64, a feature of 64-bit editions of Microsoft Windows that enables 32-bit applications to execute natively in 32-bit mode. Applications function in 32-bit mode even though the underlying operating system is running on the 64-bit operating system. WOW64 is supported only for stand-alone instances of SQL Server. WOW64 is not supported for SQL Server failover cluster installations.

3) Supported only on SQL Server SP1 or higher.

See http://msdn.microsoft.com/en-us/library/ms143506.aspx

Maybe you can cheat SQL Server by installing SQL 2008 express first, applying the SP1 and upgrading the instance to a full edition or do a slipstream installation file:


Update: I found this link http://connect.microsoft.com/SQLServer/feedback/ViewFeedback.aspx?FeedbackID=354980 with a solution in the comment section. They say that Windows Installer 4.5 must be installed which can be found here: http://www.microsoft.com/downloads/details.aspx?FamilyId=5A58B56F-60B6-4412-95B9-54D056D6F9F4&displaylang=en#filelist

  • Thanks. I tried installing Express then SP1, but got the same error message when trying to upgrade. I also got the same error message when using the slipstream version. +1 for the suggestions though, thank you. – harriyott Nov 23 '09 at 18:25
  • Thanks for the update. I'd seen that mentioned already, and Win 7 comes with Windows Installer 5. Hopefully the SQL Server installer checks with >= rather than == ;-) – harriyott Nov 24 '09 at 15:46
  • 1
    Uh, you're right...it's already written in your question ^^ Have you tried to install the server using an administrator account (maybe disable UAC for a short moment)? – Scoregraphic Nov 25 '09 at 6:58

I experienced the same problem but have now found a solution. I had extracted the contents of en_sql_server_2008_enterprise_x86_x64_ia64_dvd_x14-89207.iso (from MSDN) but not the contents of the x64 directory. So I think setup.exe was seeing that only the x86 install files were available, trying to install those, and failing. The symptoms were exactly as described in the original question and the fix was to make sure the x64 directory had been extracted.

You will still get the compatibility warning and should upgrade to SP1 after installing. You may also get another error message during the install process (can't remember the text, there are references to it elsewhere online) - if so, just close it and then redo the action that caused it and it will work correctly.


You could also try uninstalling .NET 3.5 SP1 and installing .NET 3.5 without SP1. I have seen this working with other applications before that look for specific .NET build versions in the Windows Registry. But this would seem like a pretty big slip for Microsoft to miss.

  • Thanks. I tried installing SQL Server 2008 before installing .NET 3.5 SP1, so I know that isn't the problem in this case. – harriyott Nov 23 '09 at 17:46

Your answer probably lies in this article : http://www.pluralsight-training.net/community/blogs/matt/archive/2010/03/01/getting-sql-server-2008-management-studio-express-installed-on-windows-7.aspx

It solved my issue, read the comments below, there was a minor mistake in the guide.

Hope this helps you.

  • Nope, this is not the case, on regular Windows 7 (not some RC) both entries in registy are set to 1. So it is not the issue. – greenoldman Jun 9 '11 at 18:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.