1

I’m using cassandra on a remote node I can access just with console. Since the node has a private ip, the cluster manager set a proxy to access private_ip:9042 in order to allow me to execute query against the db, so I have a public ip:port.

Unfortunately I’m not able to execute query and I’m investigate about why.

com.datastax.driver.core.exceptions.NoHostAvailableException: All host(s) tried for query failed (tried: /PUBLIC_IP:55092 (com.datastax.driver.core.exceptions.TransportException: [/PUBLIC_IP] Cannot connect))

I’m sure the procedure to execute the query is fine because I tried with an identical cassandra db developed on the localhost. I suppose the problem is in the listener set on the remote node. Using Kafka I had a similar problem but I solved it setting a variable advertised_listener in the configurations file, specifying the public_ip:port I using to access to the node. Anyway I didn’t find anything of similar in cassandra.yaml file.

Do you know how can I solve the issue?

Thank you, Andrea

0

I solved setting broadcast_rpc_address in cassandra.yaml with the remote ip.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.