I have an exchange 2013 server. We have mail contacts set up for some external contacts.

There are several distribution lists which contain these mail contacts.

When an internal user inspects the distribution list through outlook, the mail contacts are not shown.

When I open exchange shell and run

Get-DistributionGroupMember "MyGroupName"

I get the full list of users including the mail contacts.

enter image description here

enter image description here

I have checked the contacts and none of them are set to 'hide from address lists'.

Does anyone know how to include these recipients in the list as far as outlook is concerned?

The following is an output of get-mailcontact...

enter image description here

  • 1
    Can you run a get-mailcontact and share the ouput please? Also, does the problem manifest itself in OWA? Can you view the contact in the GAL OK? Does the name resolve properly if you type it into the To: field? Thanks
    – LeMoore
    Sep 14, 2017 at 9:26
  • See my edit above for output of get-mailcontact.
    – John
    Sep 18, 2017 at 10:22
  • The name does resolve properly when entered in the To: field, but doesn't seem to appear on the GAL, despite the recipient filter on the GAL being set to include mailcontacts
    – John
    Sep 18, 2017 at 10:23

1 Answer 1


So just on a fluke, I managed to solve this issue... Thanks to LeMoore, as his comment sent me down the right path. Once I realised I couldn't see the mail contacts in the GAL that got me thinking...

This is a multi-tenant mail server and isolation is achieved using filters and customattribute1.

When the mailcontacts were created, as there is no option for customattribute1, It appears that my colleagues never set it.

I applied the correct value to customattribute1 via the shell and hey presto, suddenly the users can see the mailcontacts in the GAL and they appear in the distribution lists.

Thanks for the assistance guys!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .