1

This is a rather old issue but it's starting to get more and more frequent.

We are providing an application to external users trough Citrix XenApp 6.5. The users have a number of different version of the receiver but the problem is the same even with the latest one (4.9 at the time I write this, it wa confirmed at least as far back as 4.2).

The users typically have a windows 10 system with multiple display. They attempt also have different zoom factor for each screen (display settings -> Scale and Layout).

At connection, the application gets zoomed according to the display factor of the screen is initially starts on. This works fine until the user moves one of the application's windows (even partially) to the second screen. Then several things happen:

  • The "clipping region" that Citrix uses to display the application in seamless mode get desyncronized with the actual position of the window (on the second screen only). This results in only part of the application to be displayed on the client with blue background next to it.
  • The mouse position isn't forwarded properly to the server any more in both screens: the user cannot click on any UI element because the server receives a different location that where the user clicked.

The problem can be solved by synchronizing the zoom factors of both screens but, of course, that is a major inconvenience when the user has several screens with very different DPIs (typically, a laptop or tablet with a QHD or UHD screen and a main display with a 1080p one). In such a situation, the user has more or less to stop using one of the screens.

  • Hi, try an old trick, put the open windowed receiver in between the two screen and click to maximize. – yagmoth555 Sep 14 '17 at 10:05
  • Thanks for the suggestion but it won't apply here. The application has many windows (and executables) and not all can be maximized. Furthermore, the initial launchpad cannot be maximized so the user cannot even get past it. I need a more general fix, I'm afraid – Stephane Sep 14 '17 at 12:22
  • Answer in the comment section on following post worked for me. discussions.citrix.com/topic/… – Prerak05 Sep 19 '19 at 16:35
2

Actually, I found an acceptable answer (at least for me).

The user needs to:

  • Navigate to the installation folder of the Citrix receiver client (by default, C:\Program Files (x86)\Citrix\ICA Client)
  • Select wfica32.exe and bring up file's properties.
  • Go to the Compatibility tab.
  • Enable the Override high DPI scaling behavior option
  • Under Scaling performed by select Application
  • Apply and close.

Connection will most likely needs to restarted for the parameter to be applied, but the issue is solved (at least for this user).

Properly configured dialog screenshot

|improve this answer|||||
0

I had the same issue 1920x1080 laptop screen and 1600x1050 monitor.

Citrix version 4.12.0.18020

Right click the icon in the tray and select advanced preferences, Select High DPI select "no, use the native resolution"

Fixed the issue immediately, i did have to disconnect from the session and reconnect but that might just be the companys server.

|improve this answer|||||
0

I know this is an old question but I had the same issue but with also making my mouse pointer jump all over the place if I went near the Citrix window, and as this post helped me I thought I would share to help other

I used a variation on one of the solutions here:

Right click the icon in the tray -> Select advanced preferences -> Select High DPI -> Select "yes"

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.