As a small prank on one of my coworkers I created a group policy object that forced a specific wallpaper (Desktop Background) on her profile whenever she logs in. Laughs were had by all. I deleted the GPO and expected her wallpaper to return to normal. Unfortunately, it did not. Now she is unable to change her wallpaper. When she right-clicks on the desktop and goes to "Personalize" (using Win10) there is a message that her background settings are controlled by the system administrator (Me).

[sheepish] Sooo...Ummm.... How do I undo my prank and allow her to change her own wallpaper again? [/sheepish]

  • was it pushed via local pc gpo or doman ? if you can remember the group policy you applied , see its still applying gpresult /Scope User /v .. did you gpupdate/force after you have removed your group policy ? – Aravinda Sep 14 '17 at 16:25

As far as I know, deleting the GPO only removes the enforcement of the policy. That is, it won't reapply anymore and overwrite changes to the policy. If there is not another GPO which applies and alters those same settings, they won't be changed. Any non-default settings are NOT reset to defaults just because you deleted the policy.

The easiest way to fix this would be to use another policy to reapply the default settings, then remove that GPO once it has applied.

Edit: Apparently, according to this forum post, some settings will revert, and some will not. https://social.technet.microsoft.com/Forums/windows/en-US/41a9b71d-ef34-40cc-b071-4fbbfe61acba/delete-group-policy-removes-settings?forum=w7itprosecurity

I assumed in my initial answer that you had already done a 'gpupdate /force' and had her log off and back on. If not, you should try that before resorting to the dummy policy.

  • 1
    Well, shortly after I posted this question I received a message from the user that the problem had fixed itself and she was now able to change her wallpaper again. And yes, I had already tried gpuptdate /force and reboot multiple times. Not sure why it decided to be ornery for awhile. – Brent Sep 18 '17 at 14:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.