1

Testing logstash as instructed here.

This is the command I execute (it doesn't work without the --path.settings too):

/usr/share/logstash/bin/logstash -f logstash-simple.conf --path.settings /etc/logstash/logstash.yml 

But I am getting this warning:

WARNING: Could not find logstash.yml which is typically located in $LS_HOME/config or /etc/logstash. You can specify the path using --path.settings.

Permissions should be ok for everyone to read logstash.yml:

ls -lsah /etc/
4.0K drwxrwxr-x   4 root root   4.0K Sep 15 16:35 logstash

ls -lsah /etc/logstash/
8.0K -rw-r--r--   1 root root 5.7K Sep 15 16:26 logstash.yml

Version:

/usr/share/logstash/bin/logstash --version
logstash 5.6.0
  • You only need to set the directory with --path.settings, try --path.settings /etc/logstash. If this doesn't work, try to run it as user logstash (if you have created it, depends on which user logstash runs in your environment) – Lenniey Sep 15 '17 at 8:12
  • That works. Although I would still expect that logstash finds its config file in the default place if I leave out the parameter. – kev Sep 15 '17 at 8:15
  • What happens if you run the service? This should be OK. – Lenniey Sep 15 '17 at 8:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.