-1

I am trying to configure Apache version 2.4.27 and enable ldap. I also install this library without error:

./config --prefix=/opt/lib/openssl-1.1.0f shared

make depend, make, make install

CPPFLAGS="-I/opt/lib/openssl-1.1.0f/include" LDFLAGS="-Lopt/lib/openssl-1.1.0f/lib" ./configure --prefix=/opt/lib/openldap-2.4.45 --disable-slapd --with-tls=openssl

make depend, make, make install


./configure --prefix=/opt/lib/curl-7.54.1 --with-ssl=/opt/lib/openssl-1.1.0f

make, make install

./configure --prefix=/opt/lib/pcre-8.41

make, make install       

./configure CFLAGS=-DXML_POOR_ENTROPY --prefix=/opt/lib/expat-2.2.2

make, make install

Below is the command for configuring httpd -2.4.27:

./configure --prefix=/opt/httpd-2.4.27 --with-included-apr --with-pcre=/opt/lib/pcre-8.41/ --with-ssl=/opt/lib/openssl-1.1.0f --enable-so --with-expat=/opt/lib/expat-2.2.2 --enable-suexec --with-openssl=/opt/lib/openssl-1.1.0f --with-ldap-include=/opt/lib/openldap-2.4.45/include --with-ldap-lib=/opt/lib/openldap-2.4.45/lib --with-crypto --with-ldap --enable-authnz-ldap

I put the APR(1.6.2) APR-util(1.6.0) files in the srclib directory. During the ./configure I have the following error:

checking for ldap support...
  adding "-I/opt/lib/openldap-2.4.45/include" to APRUTIL_INCLUDES
  adding "-L/opt/lib/openldap-2.4.45/lib" to APRUTIL_LDFLAGS
checking for ldap_init in -lldap50... no
checking for ldap_init in -lldapssl41... no
checking for ldap_init in -lldapssl40... no
checking for ldap_init in -lldapssl30... no
checking for ldap_init in -lldapssl20... no
checking for ldap_init in -lldapsdk... no
checking for ldap_init in -lldapsdk... no
checking for ldap_init in -lldap... no
checking for ldap_init in -lldap... no
checking for ldap_init in -lldap... no
checking for ldap_init in -lldap... no
configure: error: could not find an LDAP library
configure failed for srclib/apr-util

without LDAP I don't have any errors.

any idea?

Thanks!

5
  • 1
    I think you also need openldap-devel package. – Tux_DEV_NULL Sep 15 '17 at 7:55
  • I tried the source, but I could not find it, because I do not want to install it through rpm. Do you know if there is also the source file of the package?Thx – Simone Rizzo Sep 15 '17 at 8:15
  • What's in /opt/lib/openldap-2.4.45/lib? What symbols do those files contain? – womble Sep 15 '17 at 8:23
  • I found the problem, did not take openssl library dependencies. just export the library: export LD_LIBRARY_PATH = "/ opt / lib / openssl-1.1.0f / lib /" Thx all for support – Simone Rizzo Sep 15 '17 at 9:15
  • If you found the problem and fixed it, please write that in the "Answer" box below and then accept the answer. That might help someone else having the same issue. – Jenny D Sep 15 '17 at 9:17
1

I found the problem, did not take openssl library dependencies. just export the library: export LD_LIBRARY_PATH = "/ opt / lib / openssl-1.1.0f / lib /"

Thx all for support

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.