1

I've taken over a configuration of BareOS on Debian GNU/Linux 8 (jessie). Its a fresh install, using both file and Autochanger storage.

Everything looks correct and bconsole will talk with the changer (I can move, mount, unmout, label tapes etc.).

Problem: The backups will write to the autochanger's drive - but ONLY if the tape is manually mounted. If the drive is empty, the backup job will not pull a tape into the drive. It just stays queued indefinitely. If I move the tape to the dirve (even after the job is started) it runs fine.

The tapes are barcoded and labeled.

See pertinent config below:

bareos-dir:

Director {                            # define myself
  Name = pxxx-dir
  QueryFile = "/usr/lib/bareos/scripts/query.sql"
  Maximum Concurrent Jobs = 10
  Password = "rXjxxx"         # Console password
  Messages = Daemon
  Auditing = yes
}

Storage {
  Name = Tape
  Address = pxxx
  Password = "e9cxxx"
  Device = FlexStor_II
  Media Type = LTO-7
  Autochanger = yes
}

FileSet {
  Name = "SelfTestHuge"
  Description = "Huge fileset"
  Include {
    Options {
      Signature = MD5 # calculate md5 checksum per file
    }
    File = "/mnt/45GB-Directory"
  }
}

Job {
  Name = "BackupSelfTestTapeHuge"
  FileSet = "SelfTestHuge"
  JobDefs = "TestTapeHuge"
}

JobDefs {
  Name = "TestTapeHuge"
  Type = Backup
  Level = Full
  Client = pxxx-fd
  FileSet = "SelfTestHuge"
  Storage = Tape
  Messages = Standard
  Pool = Full
  Priority = 10
  Write Bootstrap = "/var/lib/bareos/%c.bsr"
  Full Backup Pool = Full
  Differential Backup Pool = Differential
  Incremental Backup Pool = Incremental
}



bareos-sd:

Storage {
  Name = pxxx-sd
  Maximum Concurrent Jobs = 20
}

Director {
  Name = pxxx-dir
  Password = "e9cxxx"
  Description = "Director, permitted to contact this storage daemon."
}

Autochanger {
  Name = "FlexStor_II"
  Changer Device = /dev/tape/by-id/scsi-1BDT_FlexStor_II_00MX64200449_LL0
  Device = ULTRIUM-HH7-0
  Device = ULTRIUM-HH7-1
  Changer Command = "/usr/lib/bareos/scripts/mtx-changer %c %o %S %a %d"
}

Device {
    Name = "ULTRIUM-HH7-0"
    DeviceType = tape
    DriveIndex = 0
    ArchiveDevice = /dev/tape/by-id/scsi-35000e1116b5b8001-nst
    MediaType = LTO-7
    Check Labels = yes
    AutoChanger = yes
    AutomaticMount = yes
    MaximumFileSize = 500GB
    AlwaysOpen = yes
}

Device {
    Name = "ULTRIUM-HH7-1"
    DeviceType = tape
    DriveIndex = 1
    ArchiveDevice = /dev/tape/by-id/scsi-35000e1116b5b8004-nst
    MediaType = LTO-7
    Check Labels = yes
    AutoChanger = yes
    AutomaticMount = yes
    MaximumFileSize = 500GB
    AlwaysOpen = yes
}
0

The mailing list figured it out.

I had to edit the devices (tape Ultirum drives).

First comment out...

# Check Labels = yes

and add the following...

Autoselect = yes
RemovableMedia = yes

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.