3

tried to install Mysql server from repo installed repo

wget https://dev.mysql.com/get/mysql57-community-release-el7-8.noarch.rpm
 sudo rpm -ivh mysql57-community-release-el7-8.noarch.rpm
yum update

after

yum install mysql-community-server

returned error

Error: Package: mysql-community-server-5.7.19-1.el7.x86_64 (mysql57-community)
           Requires: libstdc++.so.6(GLIBCXX_3.4.15)(64bit)
Error: Package: mysql-community-libs-5.7.19-1.el7.x86_64 (mysql57-community)
           Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: mysql-community-client-5.7.19-1.el7.x86_64 (mysql57-community)
           Requires: libstdc++.so.6(GLIBCXX_3.4.15)(64bit)
Error: Package: mysql-community-server-5.7.19-1.el7.x86_64 (mysql57-community)
           Requires: libc.so.6(GLIBC_2.17)(64bit)
Error: Package: mysql-community-client-5.7.19-1.el7.x86_64 (mysql57-community)
           Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: mysql-community-server-5.7.19-1.el7.x86_64 (mysql57-community)
           Requires: libsasl2.so.3()(64bit)
Error: Package: mysql-community-server-5.7.19-1.el7.x86_64 (mysql57-community)
           Requires: systemd

How to solve this problem?

OS version:

Linux dbmysql01 4.1.12-103.3.8.el6uek.x86_64 #2 SMP Mon Aug 21 17:27:50 PDT 2017 x86_64 x86_64 x86_64 GNU/Linux

Tryied variant by Tomas

yum remove mysql57-community-release.noarch
yum install https://dev.mysql.com/get/mysql57-community-release-el6-11.noarch.rpm
yum install mysql-community-server

returned result

Loaded plugins: security, ulninfo
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package mysql-community-server.x86_64 0:5.7.19-1.el7 will be installed
--> Processing Dependency: mysql-community-common(x86-64) = 5.7.19-1.el7 for package: mysql-community-server-5.7.19-1.el7.x86_64
--> Processing Dependency: mysql-community-client(x86-64) >= 5.7.9 for package: mysql-community-server-5.7.19-1.el7.x86_64
--> Processing Dependency: systemd for package: mysql-community-server-5.7.19-1.el7.x86_64
--> Processing Dependency: systemd for package: mysql-community-server-5.7.19-1.el7.x86_64
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.15)(64bit) for package: mysql-community-server-5.7.19-1.el7.x86_64
--> Processing Dependency: libnuma.so.1(libnuma_1.2)(64bit) for package: mysql-community-server-5.7.19-1.el7.x86_64
--> Processing Dependency: libnuma.so.1(libnuma_1.1)(64bit) for package: mysql-community-server-5.7.19-1.el7.x86_64
--> Processing Dependency: libc.so.6(GLIBC_2.17)(64bit) for package: mysql-community-server-5.7.19-1.el7.x86_64
--> Processing Dependency: libaio.so.1(LIBAIO_0.4)(64bit) for package: mysql-community-server-5.7.19-1.el7.x86_64
--> Processing Dependency: libaio.so.1(LIBAIO_0.1)(64bit) for package: mysql-community-server-5.7.19-1.el7.x86_64
--> Processing Dependency: libsasl2.so.3()(64bit) for package: mysql-community-server-5.7.19-1.el7.x86_64
--> Processing Dependency: libnuma.so.1()(64bit) for package: mysql-community-server-5.7.19-1.el7.x86_64
--> Processing Dependency: libaio.so.1()(64bit) for package: mysql-community-server-5.7.19-1.el7.x86_64
--> Running transaction check
---> Package libaio.x86_64 0:0.3.107-10.el6 will be installed
---> Package mysql.x86_64 0:5.1.73-8.0.1.el6_8 will be obsoleted
---> Package mysql-community-client.x86_64 0:5.7.19-1.el7 will be obsoleting
--> Processing Dependency: mysql-community-libs(x86-64) >= 5.7.9 for package: mysql-community-client-5.7.19-1.el7.x86_64
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.15)(64bit) for package: mysql-community-client-5.7.19-1.el7.x86_64
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: mysql-community-client-5.7.19-1.el7.x86_64
---> Package mysql-community-common.x86_64 0:5.7.19-1.el7 will be installed
---> Package mysql-community-server.x86_64 0:5.7.19-1.el7 will be installed
--> Processing Dependency: systemd for package: mysql-community-server-5.7.19-1.el7.x86_64
--> Processing Dependency: systemd for package: mysql-community-server-5.7.19-1.el7.x86_64
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.15)(64bit) for package: mysql-community-server-5.7.19-1.el7.x86_64
--> Processing Dependency: libc.so.6(GLIBC_2.17)(64bit) for package: mysql-community-server-5.7.19-1.el7.x86_64
--> Processing Dependency: libsasl2.so.3()(64bit) for package: mysql-community-server-5.7.19-1.el7.x86_64
---> Package numactl.x86_64 0:2.0.9-2.el6 will be installed
--> Running transaction check
---> Package mysql-community-client.x86_64 0:5.7.19-1.el7 will be obsoleting
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.15)(64bit) for package: mysql-community-client-5.7.19-1.el7.x86_64
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: mysql-community-client-5.7.19-1.el7.x86_64
---> Package mysql-community-libs.x86_64 0:5.7.19-1.el7 will be obsoleting
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: mysql-community-libs-5.7.19-1.el7.x86_64
---> Package mysql-community-server.x86_64 0:5.7.19-1.el7 will be installed
--> Processing Dependency: systemd for package: mysql-community-server-5.7.19-1.el7.x86_64
--> Processing Dependency: systemd for package: mysql-community-server-5.7.19-1.el7.x86_64
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.15)(64bit) for package: mysql-community-server-5.7.19-1.el7.x86_64
--> Processing Dependency: libc.so.6(GLIBC_2.17)(64bit) for package: mysql-community-server-5.7.19-1.el7.x86_64
--> Processing Dependency: libsasl2.so.3()(64bit) for package: mysql-community-server-5.7.19-1.el7.x86_64
---> Package mysql-libs.x86_64 0:5.1.73-8.0.1.el6_8 will be obsoleted
--> Processing Dependency: libmysqlclient.so.16()(64bit) for package: perl-DBD-MySQL-4.013-3.el6.x86_64
--> Processing Dependency: libmysqlclient.so.16(libmysqlclient_16)(64bit) for package: perl-DBD-MySQL-4.013-3.el6.x86_64
--> Finished Dependency Resolution
Error: Package: mysql-community-server-5.7.19-1.el7.x86_64 (mysql57-community)
           Requires: libstdc++.so.6(GLIBCXX_3.4.15)(64bit)
Error: Package: mysql-community-libs-5.7.19-1.el7.x86_64 (mysql57-community)
           Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: mysql-community-client-5.7.19-1.el7.x86_64 (mysql57-community)
           Requires: libstdc++.so.6(GLIBCXX_3.4.15)(64bit)
Error: Package: mysql-community-server-5.7.19-1.el7.x86_64 (mysql57-community)
           Requires: libc.so.6(GLIBC_2.17)(64bit)
Error: Package: perl-DBD-MySQL-4.013-3.el6.x86_64 (@public_ol6_latest)
           Requires: libmysqlclient.so.16()(64bit)
           Removing: mysql-libs-5.1.73-8.0.1.el6_8.x86_64 (@public_ol6_latest)
               libmysqlclient.so.16()(64bit)
           Obsoleted By: mysql-community-libs-5.7.19-1.el7.x86_64 (mysql57-community)
               Not found
           Available: mysql-libs-5.1.47-4.el6.x86_64 (public_ol6_latest)
               libmysqlclient.so.16()(64bit)
           Available: mysql-libs-5.1.52-1.el6_0.1.x86_64 (public_ol6_latest)
               libmysqlclient.so.16()(64bit)
           Available: mysql-libs-5.1.61-1.el6_2.1.x86_64 (public_ol6_latest)
               libmysqlclient.so.16()(64bit)
           Available: mysql-libs-5.1.61-4.el6.x86_64 (public_ol6_latest)
               libmysqlclient.so.16()(64bit)
           Available: mysql-libs-5.1.66-1.el6_3.x86_64 (public_ol6_latest)
               libmysqlclient.so.16()(64bit)
           Available: mysql-libs-5.1.66-2.el6_3.x86_64 (public_ol6_latest)
               libmysqlclient.so.16()(64bit)
           Available: mysql-libs-5.1.67-1.el6_3.x86_64 (public_ol6_latest)
               libmysqlclient.so.16()(64bit)
           Available: mysql-libs-5.1.69-1.el6_4.x86_64 (public_ol6_latest)
               libmysqlclient.so.16()(64bit)
           Available: mysql-libs-5.1.71-1.el6.x86_64 (public_ol6_latest)
               libmysqlclient.so.16()(64bit)
           Available: mysql-libs-5.1.73-3.el6_5.x86_64 (public_ol6_latest)
               libmysqlclient.so.16()(64bit)
           Available: mysql-libs-5.1.73-5.el6_6.x86_64 (public_ol6_latest)
               libmysqlclient.so.16()(64bit)
           Available: mysql-libs-5.1.73-5.el6_7.1.x86_64 (public_ol6_latest)
               libmysqlclient.so.16()(64bit)
           Available: mysql-libs-5.1.73-7.el6.x86_64 (public_ol6_latest)
               libmysqlclient.so.16()(64bit)
Error: Package: mysql-community-client-5.7.19-1.el7.x86_64 (mysql57-community)
           Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: perl-DBD-MySQL-4.013-3.el6.x86_64 (@public_ol6_latest)
           Requires: libmysqlclient.so.16(libmysqlclient_16)(64bit)
           Removing: mysql-libs-5.1.73-8.0.1.el6_8.x86_64 (@public_ol6_latest)
               libmysqlclient.so.16(libmysqlclient_16)(64bit)
           Obsoleted By: mysql-community-libs-5.7.19-1.el7.x86_64 (mysql57-community)
               Not found
           Available: mysql-libs-5.1.47-4.el6.x86_64 (public_ol6_latest)
               libmysqlclient.so.16(libmysqlclient_16)(64bit)
           Available: mysql-libs-5.1.52-1.el6_0.1.x86_64 (public_ol6_latest)
               libmysqlclient.so.16(libmysqlclient_16)(64bit)
           Available: mysql-libs-5.1.61-1.el6_2.1.x86_64 (public_ol6_latest)
               libmysqlclient.so.16(libmysqlclient_16)(64bit)
           Available: mysql-libs-5.1.61-4.el6.x86_64 (public_ol6_latest)
               libmysqlclient.so.16(libmysqlclient_16)(64bit)
           Available: mysql-libs-5.1.66-1.el6_3.x86_64 (public_ol6_latest)
               libmysqlclient.so.16(libmysqlclient_16)(64bit)
           Available: mysql-libs-5.1.66-2.el6_3.x86_64 (public_ol6_latest)
               libmysqlclient.so.16(libmysqlclient_16)(64bit)
           Available: mysql-libs-5.1.67-1.el6_3.x86_64 (public_ol6_latest)
               libmysqlclient.so.16(libmysqlclient_16)(64bit)
           Available: mysql-libs-5.1.69-1.el6_4.x86_64 (public_ol6_latest)
               libmysqlclient.so.16(libmysqlclient_16)(64bit)
           Available: mysql-libs-5.1.71-1.el6.x86_64 (public_ol6_latest)
               libmysqlclient.so.16(libmysqlclient_16)(64bit)
           Available: mysql-libs-5.1.73-3.el6_5.x86_64 (public_ol6_latest)
               libmysqlclient.so.16(libmysqlclient_16)(64bit)
           Available: mysql-libs-5.1.73-5.el6_6.x86_64 (public_ol6_latest)
               libmysqlclient.so.16(libmysqlclient_16)(64bit)
           Available: mysql-libs-5.1.73-5.el6_7.1.x86_64 (public_ol6_latest)
               libmysqlclient.so.16(libmysqlclient_16)(64bit)
           Available: mysql-libs-5.1.73-7.el6.x86_64 (public_ol6_latest)
               libmysqlclient.so.16(libmysqlclient_16)(64bit)
Error: Package: mysql-community-server-5.7.19-1.el7.x86_64 (mysql57-community)
           Requires: libsasl2.so.3()(64bit)
Error: Package: mysql-community-server-5.7.19-1.el7.x86_64 (mysql57-community)
           Requires: systemd
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

tried other variant

yum remove mysql57-community-release.noarch
yum clean all
yum install https://dev.mysql.com/get/mysql57-community-release-el6-11.noarch.rpm
yum install mysql-community-server

again returned error

Error: Package: mysql-community-client-5.7.19-1.el7.x86_64 (mysql57-community)
           Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: perl-DBD-MySQL-4.013-3.el6.x86_64 (@public_ol6_latest)
           Requires: libmysqlclient.so.16(libmysqlclient_16)(64bit)
           Removing: mysql-libs-5.1.73-8.0.1.el6_8.x86_64 (@public_ol6_latest)
               libmysqlclient.so.16(libmysqlclient_16)(64bit)
           Obsoleted By: mysql-community-libs-5.7.19-1.el7.x86_64 (mysql57-community)
               Not found
           Available: mysql-libs-5.1.47-4.el6.x86_64 (public_ol6_latest)
               libmysqlclient.so.16(libmysqlclient_16)(64bit)
           Available: mysql-libs-5.1.52-1.el6_0.1.x86_64 (public_ol6_latest)
               libmysqlclient.so.16(libmysqlclient_16)(64bit)
           Available: mysql-libs-5.1.61-1.el6_2.1.x86_64 (public_ol6_latest)
               libmysqlclient.so.16(libmysqlclient_16)(64bit)
           Available: mysql-libs-5.1.61-4.el6.x86_64 (public_ol6_latest)
               libmysqlclient.so.16(libmysqlclient_16)(64bit)
           Available: mysql-libs-5.1.66-1.el6_3.x86_64 (public_ol6_latest)
               libmysqlclient.so.16(libmysqlclient_16)(64bit)
           Available: mysql-libs-5.1.66-2.el6_3.x86_64 (public_ol6_latest)
               libmysqlclient.so.16(libmysqlclient_16)(64bit)
           Available: mysql-libs-5.1.67-1.el6_3.x86_64 (public_ol6_latest)
               libmysqlclient.so.16(libmysqlclient_16)(64bit)
           Available: mysql-libs-5.1.69-1.el6_4.x86_64 (public_ol6_latest)
               libmysqlclient.so.16(libmysqlclient_16)(64bit)
           Available: mysql-libs-5.1.71-1.el6.x86_64 (public_ol6_latest)
               libmysqlclient.so.16(libmysqlclient_16)(64bit)
           Available: mysql-libs-5.1.73-3.el6_5.x86_64 (public_ol6_latest)
               libmysqlclient.so.16(libmysqlclient_16)(64bit)
           Available: mysql-libs-5.1.73-5.el6_6.x86_64 (public_ol6_latest)
               libmysqlclient.so.16(libmysqlclient_16)(64bit)
           Available: mysql-libs-5.1.73-5.el6_7.1.x86_64 (public_ol6_latest)
               libmysqlclient.so.16(libmysqlclient_16)(64bit)
           Available: mysql-libs-5.1.73-7.el6.x86_64 (public_ol6_latest)
               libmysqlclient.so.16(libmysqlclient_16)(64bit)
Error: Package: mysql-community-server-5.7.19-1.el7.x86_64 (mysql57-community)
           Requires: libsasl2.so.3()(64bit)
Error: Package: mysql-community-server-5.7.19-1.el7.x86_64 (mysql57-community)
           Requires: systemd
4
  • What is the output of uname -a? Add that to your question. – Thomas Sep 16 '17 at 10:18
  • I added info about OS – Nikolay Baranenko Sep 17 '17 at 5:19
  • Do you have mysql previous version ? it looks like obsolete dependencies already there for libstdc++.so.6 , libc.so.6, libsasl2.so.3,,,,, you have to remove them first . but careful if its prod, other apps may depend on that obsolete dependencies – Aravinda Sep 17 '17 at 6:06
  • el7 but you are using el6. – c4f4t0r Sep 17 '17 at 8:24
8

From the kernel version you have posted, it seems you are running Oracle Linux 6 and you should download the Red Hat Enterprise Linux 6 / Oracle Linux 6 version instead of version 7 as you tried now.

So, the following commands should work for you.

yum remove mysql57-community-release.noarch
yum clean all
yum install https://dev.mysql.com/get/mysql57-community-release-el6-11.noarch.rpm
yum install mysql-community-server
5
  • tried your variant and result added to question – Nikolay Baranenko Sep 17 '17 at 14:58
  • Sorry, forgot to clean up the yum cache. Edited the answer. You can just try to yum clean all, then yum install mysql-community-server. Just tested in a VM with Centos6. – Thomas Sep 17 '17 at 15:15
  • tryied else time and again returned error – Nikolay Baranenko Sep 17 '17 at 20:50
  • Unfortunately, Oracle mysql 57 did not install to Oracle Linux 6.9, case mysql 57 requires version lib glibc.x86_64 = 2.17, in Oracle Linux 6.9 only 2.12 – Nikolay Baranenko Sep 18 '17 at 11:05
  • There is still something wrong with your repositories or the yum cache. As you can see from the second output above, yum still tries to install mysql-community-server.x86_64 0:5.7.19-1.el7 which is for REHL7/CentOS7 based systems. Therefore the wrong libc version is pulled in. Remove any mysql package that might have been installed. Check your repositories again in /etc/yum.repos.d/ and remove anything that is related to RHEL7/CentOS7. Do a yum clean all again. – Thomas Sep 20 '17 at 10:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.