0

I have 2 servers with windows and ubuntu running in Amazon EC2. I created the FTP server using plesk in windows and used vsftpd in the ubuntu. I have enabled all TCP ports in both the servers. The vsftpd is running in the passive mode in ubuntu.

The accessing the ftp from the remote place is working fine in both the server, But my backup program (Backup maker) seems to have the problem with both the FTP servers in EC2 (backup program is running in server located outside the Amazon). At the end of the backup it says that the size is mismatched and it aborts the backup. But when i compared there is no difference between files after backup and before backup.

For the compilation of error i checked by changing destination FTP server in backup software from amazon to some other FTP server and backup works fine. I only receive this problem in the Amazon EC2 servers irrespective of OS running in it.

And i have another problem with the FTP server running in EC2 with windows OS which is - i can not use wget utility to download the files in FTP servers. I also have anonymous FTP enabled in this server.

Please help me to resolve these errors.

1

Vsftpd use some high numbered ports for passive mode connections.

Check your security group and add two rules: Custom TCP Rule TCP 10090 - 10100 0.0.0.0/0 Custom UDP Rule UDP 10090 - 10100 0.0.0.0/0

I would bet that fixes up your problem. If you look in your config, you probably have a block like this?

pasv_enable=Yes
pasv_max_port=10100
pasv_min_port=10090

Ref: How to configure vsftpd to work with passive mode

  • 1
    Hey Daryl thank you for responding. In the above mentioned setting i only missed out UDP part. After enabling UDP port FTP working properly now. – IT researcher Oct 6 '17 at 4:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.