0

I am facing a problem within my network.

The scenario is this.

I have two HP 2920-24G Switch (J9726A). They are connected with each other and also both are connected to a HP V1910-24G Switch (JE006A) and a 3Com Baseline Switch 2952-SFP Plus.

The ports between those switches are not in trunk mode.

When I put the ports in trunk mode, I lost connection within my network. With a serial cable connected to the HP V1910-24G Switch (JE006A) switch, I can see the port I putted in trunk going up and down. Below is the log error:

Jul 31 17:49:20:338 2017 SW03 IFNET/4/INTERFACE UPDOWN: Trap 1.3.6.1.6.3.1.1.5.3: Interface 9437206 is Down, ifAdminStatus is 1, >ifOperStatus is 2

Jul 31 17:49:20:520 2017 SW03 IFNET/4/LINK UPDOWN: GigabitEthernet1/0/23: link status is DOWN

Jul 31 17:49:22:819 2017 SW03 IFNET/4/INTERFACE UPDOWN: Trap 1.3.6.1.6.3.1.1.5.4: Interface 9437206 is Up, ifAdminStatus is 1, >ifOperStatus is 1

Jul 31 17:49:23:00 2017 SW03 MSTP/1/PFWD:hwPortMstiStateForwarding: >Instance 0's Port 0.9437206 has been set to forwarding state!

Jul 31 17:49:23:160 2017 SW03 IFNET/4/LINK UPDOWN: GigabitEthernet1/0/23: link status is UP

Jul 31 17:49:23:280 2017 SW03 MSTP/2/PFWD:Instance 0's >GigabitEthernet1/0/23 has been set to forwarding state!

This happens on the other switches as well.

I have 8 vlans that are all configured in all switches across the network. The management vlan is 1 (default).

I don't have the ports in trunk mode now because the problem.

Is this a STP problem?

Where and what should I look for? How could I solve this problem?

Here is the image with the scenario I described above

enter image description here

Here are the configs:

SWSRV01
Running configuration:

; J9726A Configuration Editor; Created on release #WB.15.16.0006
; Ver #06:0c.fc.f3.ff.35.0d:c2

hostname "SWSRV01"
module 1 type j9726a
console idle-timeout 600
password minimum-length 10
timesync sntp
sntp unicast
sntp server priority 1 10.10.1.12
no telnet-server
time timezone -180
no web-management
web-management ssl
snmp-server community "public" operator
snmp-server host 10.10.1.60 community "public" trap-level all
snmp-server contact "9877" location "Rack"
oobm
   ip address dhcp-bootp
   exit
vlan 1
   name "DEFAULT"
   untagged 1-24,A1-A2,B1-B2
   ip address 10.10.1.100 255.255.254.0
   exit
vlan 100
   name "100"
   no ip address
   exit
vlan 110
   name "110"
   no ip address
   exit
vlan 120
   name "120"
   no ip address
   exit
vlan 130
   name "130"
   no ip address
   exit
vlan 140
   name "140"
   no ip address
   exit
vlan 150
   name "150"
   no ip address
   exit
vlan 160
   name "160"
   no ip address
   exit
vlan 170
   name "170"
   no ip address
   exit
spanning-tree
spanning-tree mode rapid-pvst
spanning-tree vlan 1 root primary
spanning-tree root primary
no tftp server
no autorun
no dhcp config-file-update
no dhcp image-file-update
password manager 
password operator
---------------
SRV02

Running configuration:

; J9726A Configuration Editor; Created on release #WB.15.16.0006
; Ver #06:0c.fc.f3.ff.35.0d:c2

hostname "SWSRV02"
module 1 type j9726a
timesync sntp
sntp unicast
sntp server priority 1 10.10.1.12
no telnet-server
time timezone -180
no web-management
web-management ssl
ip default-gateway 10.10.1.252
snmp-server community "public"
snmp-server host 10.10.1.60 community "public" trap-level all
snmp-server contact "9877" location "Rack"
oobm
   ip address dhcp-bootp
   exit
vlan 1
   name "DEFAULT"
   untagged 1-24,A1-A2,B1-B2
   ip address 10.10.1.101 255.255.254.0
   exit
vlan 100
   name "100"
   no ip address
   exit
vlan 110
   name "110"
   no ip address
   exit
vlan 120
   name "120"
   no ip address
   exit
vlan 130
   name "130"
   no ip address
   exit
vlan 140
   name "140"
   no ip address
   exit
vlan 150
   name "150"
   no ip address
   exit
vlan 160
   name "160"
   no ip address
   exit
vlan 170
   name "170"
   no ip address
   exit
spanning-tree
spanning-tree mode rapid-pvst
spanning-tree priority 2
no tftp server
no autorun
no dhcp config-file-update
no dhcp image-file-update
password manager
password operator
1

Since you've got redundant links, (R)STP is required. You need to select a root switch and set it to low STP priority (otherwise the root switch is rather random and can lead to frequent reconvergence and flapping ports).

With redundant links, ONLY set up an aggregation trunk when all links run between the same two switches. Trunk groups with more than two switches require distributed trunking/MLAG which all three types lack AFAIK. VLAN trunks are no problem.

If this doesn't answer your question please post the configs.

  • I just added the configs in the main question. – FredU Sep 18 '17 at 20:27
  • The 1910 and the 2952 are not compatible with RPVST (I'm not familiar with that) - you might be better off with MSTP (or RSTP since all spanning trees seem to have SWSRV01 as root anyway) which all switches are compatible to. Your VLANs don't have any ports assign to them - is that because of your problems? – Zac67 Sep 18 '17 at 21:10
  • Zac67, I didn't assign any port the VLANs wet because of my problem. So the HP 1910 and 2952 are not compatible with RPVST? I will look for the MSTP or RSTP then. – FredU Sep 19 '17 at 11:11
  • if I configure SWSRV01 as a commander and SRV02 as a member in a stacking configuration, do you think it might resolve the situation? – FredU Sep 26 '17 at 12:18
  • With these HP switches, stacking has no effect on spanning tree; they stack only logically - trunking and redundant link blocking must still be configured. – Zac67 Sep 26 '17 at 18:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.