0

I have debian jessie, with fail2ban v0.8.13 and virtualmin. I use iptables but firewallD was install and uinstall maybe it's the problem.... the problem is: the think for all Jail

2017-09-20 11:33:45,474 fail2ban.actions.action[17998] INFO HINT on 7f00: "Command not found". Make sure that all commands in 'ipset create fail2ban-apache-noscript hash:ip timeout 600\nfirewall-cmd --direct --add-rule ipv4 filter INPUT 0 -p tcp -m multiport --dports http,https -m set --match-set fail2ban-apache-noscript src -j REJECT --reject-with icmp-port-unreachable' are in the PATH of fail2ban-server process (grep -a PATH= /proc/pidof -x fail2ban-server/environ). You may want to start "fail2ban-server -f" separately, initiate it with "fail2ban-client reload" in another shell session and observe if additional informative error messages appear in the terminals.

it looks like there are still traces of firewallD --> nfirewall-cmd I have already uninstall/install fail2ban and uninstall with purge option firewallD.

1

Seems to me that during the fail2ban installation the firewalld was present, fail2ban installer detected it and created appropriate configuration for this scenario in fail2ban.

You should look for firewalld configuration in /etc/fail2ban/jail.d especially for file /etc/fail2ban/jail.d/00-firewalld.conf
Removing those files and restarting fail2ban should fix your issue, just like removing fail2ban with purge option and reinstalling it from scratch

  • removing /etc/fail2ban/jail.d/00-firewalld.conf and restart have no effect. but edit /etc/fail2ban/jail.d/00-firewalld.conf and replace banaction = firewall-cmd by banaction = iptables-allports fix the issue I hope its stable ? – chrystophe Sep 20 '17 at 11:07
  • perhaps you had firewalld configuration in another file too, this should be stable until you issue some kind of automatic reconfiguration of fail2ban ie by dpkg-reconfigure fail2ban. Perhaps it will now see that firewalld is missing but I cannot guarantee it without access to this machine. – bocian85 Sep 20 '17 at 11:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.