0

Running ApacheHaus build of 2.4.25 of Apache on Windows.

Using Oracle Weblogic Server Plugin 12.2.1.3 Unpacked \fmw_12.2.1.3.0_wlsplugins_Disk1_1of1\WLSPlugins12c-12.2.1.3.0\WLSPlugin12.2.1.3.0-Apache2.2-Apache2.4-Win64-12.2.1.3.0\lib to C:\apps\Apache24\wl_plugin\lib

Made sure PATH contains C:\apps\Apache24\wl_plugin\lib

Set apache config to include the plugin:

LoadModule weblogic_module C:\apps\Apache24\wl_plugin\lib\mod_wl_24.so

Start the httpd:

C:\apps\Apache24\bin>httpd
httpd: Syntax error on line 180 of C:/apps/Apache24/conf/httpd.conf: Cannot load
 C:\\apps\\Apache24\\wl_plugin\\lib\\mod_wl_24.so into server: The specified module could not be found.

Obviously the module is here, and it's a misleading message as the module couldn't load due to SOMETHING being wrong.

But how do I find out what's wrong?

The docs from oracle state:

> Configuring the apache plug-in (for demo purposes only)

  1. Make a copy of %APACHE_HOME%\conf\httpd.conf file

  2. Load the plug-in module

    A) With Apache HTTP Server 2.2.x:

    Edit the file and, add the following:

    ... LoadModule weblogic_module C:\myhome\weblogic-plugins\lib\mod_wl.so

    WebLogicHost wls-host WebLogicPort wls-port

    SetHandler weblogic-handler ...

    B) With Apache HTTP Server 2.4.x:

    Edit the file and, add the following: ... LoadModule weblogic_module C:\myhome\weblogic-plugins\lib\mod_wl_24.so

    WebLogicHost wls-host WebLogicPort wls-port

    SetHandler weblogic-handler ...

  3. Ensure that the %PLUGIN_HOME%\lib is included in the PATH:

    set PATH=C:\myhome\weblogic-plugins\lib:...

    (Other options include copying the 'lib' contents to APACHE_HOME\lib or editing the APACHE_HOME\bin\apachectl to update the PATH)

  4. Start Apache HTTP Server:

    %APACHE_HOME%\bin\httpd.exe

  5. Send a request to http://apache-host:apache-port/mywebapp/my.jsp from the browser. Validate the response.

I've also tried putting lib*.dll into the apache lib folder, moving the .so to modules and loading as modules\mod_wl_24.so but I get the same issue (with a different path)

How can I drill in to see what's causing the module to not load?

EDIT

Ok so here's the output of httpd.exe -e trace8:

[Thu Sep 21 09:12:55.973025 2017] [so:debug] [pid 644:tid 228] mod_so.c(266): AH01575: loaded module access_compat_module from C:/apps/Apache24/modules/mod_access_compat.so
[Thu Sep 21 09:12:55.988620 2017] [so:debug] [pid 644:tid 228] mod_so.c(266): AH01575: loaded module actions_module from C:/apps/Apache24/modules/mod_actions.so
[Thu Sep 21 09:12:55.988620 2017] [so:debug] [pid 644:tid 228] mod_so.c(266): AH01575: loaded module alias_module from C:/apps/Apache24/modules/mod_alias.so
[Thu Sep 21 09:12:55.988620 2017] [so:debug] [pid 644:tid 228] mod_so.c(266): AH01575: loaded module allowmethods_module from C:/apps/Apache24/modules/mod_allowmethods.so
[Thu Sep 21 09:12:55.988620 2017] [so:debug] [pid 644:tid 228] mod_so.c(266): AH01575: loaded module asis_module from C:/apps/Apache24/modules/mod_asis.so
[Thu Sep 21 09:12:55.988620 2017] [so:debug] [pid 644:tid 228] mod_so.c(266): AH01575: loaded module auth_basic_module from C:/apps/Apache24/modules/mod_auth_basic.so
[Thu Sep 21 09:12:55.988620 2017] [so:debug] [pid 644:tid 228] mod_so.c(266): AH01575: loaded module authn_core_module from C:/apps/Apache24/modules/mod_authn_core.so
[Thu Sep 21 09:12:55.988620 2017] [so:debug] [pid 644:tid 228] mod_so.c(266): AH01575: loaded module authn_file_module from C:/apps/Apache24/modules/mod_authn_file.so
[Thu Sep 21 09:12:55.988620 2017] [so:debug] [pid 644:tid 228] mod_so.c(266): AH01575: loaded module authz_core_module from C:/apps/Apache24/modules/mod_authz_core.so
[Thu Sep 21 09:12:55.988620 2017] [so:debug] [pid 644:tid 228] mod_so.c(266): AH01575: loaded module authz_groupfile_module from C:/apps/Apache24/modules/mod_authz_groupfile.so
[Thu Sep 21 09:12:55.988620 2017] [so:debug] [pid 644:tid 228] mod_so.c(266): AH01575: loaded module authz_host_module from C:/apps/Apache24/modules/mod_authz_host.so
[Thu Sep 21 09:12:55.988620 2017] [so:debug] [pid 644:tid 228] mod_so.c(266): AH01575: loaded module authz_user_module from C:/apps/Apache24/modules/mod_authz_user.so
[Thu Sep 21 09:12:55.988620 2017] [so:debug] [pid 644:tid 228] mod_so.c(266): AH01575: loaded module autoindex_module from C:/apps/Apache24/modules/mod_autoindex.so
[Thu Sep 21 09:12:55.988620 2017] [so:debug] [pid 644:tid 228] mod_so.c(266): AH01575: loaded module cgi_module from C:/apps/Apache24/modules/mod_cgi.so
[Thu Sep 21 09:12:55.988620 2017] [so:debug] [pid 644:tid 228] mod_so.c(266): AH01575: loaded module dir_module from C:/apps/Apache24/modules/mod_dir.so
[Thu Sep 21 09:12:55.988620 2017] [so:debug] [pid 644:tid 228] mod_so.c(266): AH01575: loaded module env_module from C:/apps/Apache24/modules/mod_env.so
[Thu Sep 21 09:12:55.988620 2017] [so:debug] [pid 644:tid 228] mod_so.c(266): AH01575: loaded module headers_module from C:/apps/Apache24/modules/mod_headers.so
[Thu Sep 21 09:12:55.988620 2017] [so:debug] [pid 644:tid 228] mod_so.c(266): AH01575: loaded module include_module from C:/apps/Apache24/modules/mod_include.so
[Thu Sep 21 09:12:55.988620 2017] [so:debug] [pid 644:tid 228] mod_so.c(266): AH01575: loaded module isapi_module from C:/apps/Apache24/modules/mod_isapi.so
[Thu Sep 21 09:12:55.988620 2017] [so:debug] [pid 644:tid 228] mod_so.c(266): AH01575: loaded module log_config_module from C:/apps/Apache24/modules/mod_log_config.so
[Thu Sep 21 09:12:55.988620 2017] [so:debug] [pid 644:tid 228] mod_so.c(266): AH01575: loaded module mime_module from C:/apps/Apache24/modules/mod_mime.so
[Thu Sep 21 09:12:55.988620 2017] [so:debug] [pid 644:tid 228] mod_so.c(266): AH01575: loaded module negotiation_module from C:/apps/Apache24/modules/mod_negotiation.so
[Thu Sep 21 09:12:55.988620 2017] [so:debug] [pid 644:tid 228] mod_so.c(266): AH01575: loaded module proxy_module from C:/apps/Apache24/modules/mod_proxy.so
[Thu Sep 21 09:12:55.988620 2017] [so:debug] [pid 644:tid 228] mod_so.c(266): AH01575: loaded module proxy_http_module from C:/apps/Apache24/modules/mod_proxy_http.so
[Thu Sep 21 09:12:55.988620 2017] [so:debug] [pid 644:tid 228] mod_so.c(266): AH01575: loaded module setenvif_module from C:/apps/Apache24/modules/mod_setenvif.so
httpd: Syntax error on line 180 of C:/apps/Apache24/conf/httpd.conf: Cannot load C:\\apps\\Apache24\\wl_plugin\\lib\\mod_wl_24.so into server: The specified module could not be found.  

PAth is:

C:\apps\Apache24\bin>set path
Path=C:\ProgramData\Oracle\Java\javapath;C:\Windows\system32;C:\Windows;C:\Windo
ws\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Program Files (x
86)\Microsoft SQL Server\130\DTS\Binn\;C:\Program Files\Microsoft SQL Server\130
\DTS\Binn\;C:\Program Files\Microsoft SQL Server\Client SDK\ODBC\130\Tools\Binn\
;C:\Program Files (x86)\Microsoft SQL Server\130\Tools\Binn\;C:\Program Files\Mi
crosoft SQL Server\130\Tools\Binn\;C:\Program Files (x86)\Microsoft SQL Server\C
lient SDK\ODBC\130\Tools\Binn\;C:\Program Files (x86)\Microsoft SQL Server\130\T
ools\Binn\ManagementStudio\;c:\users\administrator\documents;C:\apps\Apache24\wl
_plugin\lib\

Here's the contents of c:\apps\apache24\wl_plugin\lib:

Directory of C:\apps\Apache24\wl_plugin\lib

20/09/2017  16:37    <DIR>          .
20/09/2017  16:37    <DIR>          ..
17/08/2017  21:50           451,072 mod_wl.so
17/08/2017  21:50           451,072 mod_wl_24.so
17/08/2017  21:50           641,536 oci.dll
17/08/2017  21:50         1,066,496 oraasmclnt12.dll
17/08/2017  21:50           488,960 oracell12.dll
17/08/2017  21:50         5,630,464 oraclient12.dll
17/08/2017  21:50           265,216 oraclsce12.dll
17/08/2017  21:50         6,919,680 oracommon12.dll
17/08/2017  21:50         1,755,136 oracore12.dll
17/08/2017  21:50        19,112,960 orageneric12.dll
17/08/2017  21:50        10,691,072 orahasgen12.dll
17/08/2017  21:50           737,280 oraldapclnt12.dll
17/08/2017  21:50         4,529,152 oran12.dll
17/08/2017  21:50             8,192 orancds12.dll
17/08/2017  21:50           100,864 orancrypt12.dll
17/08/2017  21:50            22,016 oranhost12.dll
17/08/2017  21:50           535,552 oranl12.dll
17/08/2017  21:50           284,160 oranldap12.dll
17/08/2017  21:50         1,041,408 oranls12.dll
17/08/2017  21:50         5,019,136 orannzsbb12.dll
17/08/2017  21:50           339,456 oranro12.dll
17/08/2017  21:50           190,464 orantcp12.dll
17/08/2017  21:50            41,984 orantns12.dll
17/08/2017  21:50         1,218,048 oraocr12.dll
17/08/2017  21:50           956,416 oraocrb12.dll
17/08/2017  21:50            84,480 oraocrutl12.dll
17/08/2017  21:50           220,160 oraons.dll
17/08/2017  21:50            51,712 oraonsssl.dll
17/08/2017  21:50            22,528 oraonssys.dll
17/08/2017  21:50         4,205,056 oraplp12.dll
17/08/2017  21:50         6,395,392 orapls12.dll
17/08/2017  21:50            35,840 oraslax12.dll
17/08/2017  21:50           241,664 orasnls12.dll
17/08/2017  21:50           310,784 orasql12.dll
17/08/2017  21:50           105,472 oraunls12.dll
17/08/2017  21:50             9,728 orauts.dll
17/08/2017  21:50            10,240 oravsn12.dll
17/08/2017  21:50           236,544 orawsec12.dll
17/08/2017  21:50         7,452,672 oraxml12.dll
17/08/2017  21:50           126,976 orazt12.dll
17/08/2017  21:50         1,463,296 oraztkg12.dll
17/08/2017  21:50           281,088 yod.dll
              42 File(s)     83,751,424 bytes
               2 Dir(s)  19,297,947,648 bytes free

HTTPD.conf says:

LoadModule weblogic_module "C:\apps\Apache24\wl_plugin\lib\mod_wl_24.so"

* FURTHER EDIT * I've now downgraded to 12.1.3 of the mod_wl_24 and it works, so it's obviously an issue with the release, but I'd still like to know if there is more I can do to investigate why 12.2.1.3 fails to load, as we were looking to upgrade to the latest as some of the fixes apply to us.

5
  • do you get a more specific message from the error log? I'm not familiar with using this in windows, but I am with Linux. Show the contents of the lib dir in the question. – ezra-s Sep 20 '17 at 18:04
  • @ezra-s I've updated the original post with more details. – THEMike Sep 21 '17 at 8:16
  • silly question but, your system is 64 bits right? Anyways, the big difference between 12.1.3 and 12.2.1.x is tha the first does not have dependencies on other libs, at least not in linux, while the latter version requires the lib PATH, in case of Linux, LD_LIBRARY_PATH pointing to the lib directory, make double sure the the path is correctly loaded in the environment when httpd starts, for the user httpd starts and for the httpd user httpd starts with, or try to load the path manually and run httpd.exe yourself (with non-priviledged port and all that and see if module loads). – ezra-s Sep 21 '17 at 18:07
  • Yes, running a full 64bit platform, 64bit VM running Windows Server 2012 R2 (64bit) with 64bit apache The 12.1.3 also said it needed the LIB stuff. I had the lib dlls on the path. My deploymnet of 12.1.3 and 12.2.1.x was identical as far as I could see. Was launching httpd from an admin command prompt etc and verified path first. – THEMike Sep 23 '17 at 8:01
  • well, try yourself, again, manually, and make 100% sure. – ezra-s Sep 25 '17 at 16:06
1

I had the same problem on Win7 x64, it turns out I needed to install Microsoft Visual C++ Redistributable (x64) for Visual Studio 2012

0

The game has changed for WebLogic 12.2.1.3.0 and Apache 2.4. You now need to install the following.

These kinds of dependencies really ought to be documented by Oracle.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.