4

I have 4-node S2D cluster with 12 disks each on Windows Server 2016 Insider Preview 16257. I applied this settings by Cosmos Darwin to prevent adding new disks to the pool automatically

Is there any way to prevent Storage Spaces Direct from automatically adding disks?

but when I connect new disk, with this cmdlet I can see (after few minutes), that the new disks are in the pool

(Get-PhysicalDisk | ? mediatype -eq hdd).cannotpoolreason

Is there another settings to modify? Is it possible to use local disk in every node within Storage Spaces Direct? Thank you

4

Nope. As a workaround you may want to patch the registry and ask your disks to report S2D-incompatible drive type, they will be ignored by S2D by default in such a case.

https://www.starwindsoftware.com/blog/resolving-enable-clusters2d-bus-type-support-issue-on-some-storage-controllers

| improve this answer | |
1

I second the BaronSamedi1958's answer. There is nothing else could be done. And yet Storage Spaces Direct is too buggy to run production. I believe you use Preview version for nothing but evaluation.

A similar thread on TechNet https://social.technet.microsoft.com/Forums/en-US/c743e652-012b-4145-893e-105474a9189e/s2d-auto-pooling?forum=winserverfiles

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.