1

We have a server 2008 r2 virtual machine that's acting as a public facing RDP terminal (I know I know, that's a whole different fight). I'm trying to set RDP to use any port but 3389, but I get the "this computer is unavailable" message whenever I change the port. What I'm doing is:

1) Changing the port used by RDP in the registry (HKEY_LOCAL_MACHINE > SYSTEM > CurrentControlSet > Control > Terminal Server > WinStations > RDP-Tcp > PortNumber field)

2) Changing the symantec firewall rule that allows traffic on port 3389 to port (for example) 4000. (Windows firewall is disabled, and I've made sure the service isn't running in services.msc)

3) Try to open an RDP session from another computer on the LAN to x.x.x.x:4000

When I use netstat -a it says TCP is listening on port 4000, but RDP connections fail with the "the computer is offline error". When I do the exact steps as above with 3389 it works, anyone know what's up?

  • A simple question, but server rebooted after the reg change ? as it should work – yagmoth555 Sep 25 '17 at 3:32
  • 1
    Unfortunately, you've indicated that you've done everything correctly. But, clearly something is still blocking that port. It's time to uninstall Symantec. – Appleoddity Sep 25 '17 at 4:17
0

Export the registry from the working one and import into the broken one

HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.