0

Ok here is the scenario. A couple of days ago our firewall (a domain joined TMG also configured for NAT and VPN gateway) server got compromised. As a result, it was taken down immediately and replaced the NAT gateway with a small router(temporarily) until a suitable device is arranged.

DCHP service is running on a DC and is leasing addresses ok. However, the servers on the network now have a yellow exclamation mark on the network connection indicating the network connection as unauthenticated and network profile on the servers is now set to public. When changing the network profile to domain it goes back to public automatically This is causing multiple issues on the network due to the

The servers are able to contact DNS, DHCP server, and internet

Servers are also able to contact the domain controllers Symantec SEP is used as a firewall on the servers.

Any ideas what could be causing this problem.?

  • 1
    What do the domain clients use as their DNS servers? What does the DC use as it's DNS server (in the TCP/IP settings of the NIC on the DC)? Do you have more than one DC and is the DNS role installed and hosting the AD DNS zone? – joeqwerty Sep 26 '17 at 0:53
0

Did you move the DHCP service during this time?

The Network Location Awareness (NLA) Service controls the location setting on the firewall.

Your problem is that Windows is not detecting that it is on the "domain" network, because your "Connection Specific DNS Suffix" does not match your domain name.

Make sure you have configured your DHCP server's DNS domain name (Option 15) to match your AD domain name. i.e. If your domain is corp.local then DHCP should hand out corp.local as the DNS domain name. And, you should see this listed on the "Connection Specific DNS Suffix" for the network interface when you use ipconfig /all.

I've also seen a bug on Server 2012 numerous times where the NLA service causes the server to drop into the "public" zone after a reboot. You should change the NLA service to Delayed Startup to solve this issue. If your server is currently stuck in the Public zone, then you can also restart the NLA service to get it back to normal.

Last, make SURE DHCP is completely disabled on the router you plugged in for both IPv4 and IPv6.

Here is more information on the NLA service: https://blogs.technet.microsoft.com/networking/2010/09/08/network-location-awareness-nla-and-how-it-relates-to-windows-firewall-profiles/

And on Option 15: https://technet.microsoft.com/en-us/library/dd572752(v=office.13).aspx

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.