0

On my freebsd, when ip and network conf is given by the dhcp, these routes are added for unknown reason :

192.168.138.6      54:a0:xx:xx:xx:xx  UHS    re0_vlan100
192.168.138.5      54:a0:xx:xx:xx:xx  UHS    re0_vlan100

The mac address is the one of my computer interface, and the IPs are for the local DNS servers :

root@ox2:~ # cat /etc/resolv.conf 
domain localhost.localdomain
nameserver 192.168.138.6
nameserver 192.168.138.5
nameserver 208.67.222.222 (opendns manually added)
nameserver 8.8.8.8 (google dns manually added)

Which are given by dhcp :

lease {
   interface "re0_vlan100";
   fixed-address 172.17.4.92;
   option subnet-mask 255.255.0.0;
   option routers 172.17.0.1;
   option domain-name-servers 192.168.138.6,192.168.138.5;
   option broadcast-address 172.17.255.255;
   option dhcp-lease-time 172800;
   option dhcp-message-type 5;
   option dhcp-server-identifier 192.168.138.5;
   renew 3 2017/9/27 10:27:40;
   rebind 4 2017/9/28 04:27:40;
   expire 4 2017/9/28 10:27:40;
}

Because of these routes, querying the defaults dns fails. Deleting the routes fix the problem, until the lease is renewed...

Where do these routes come from ? And how do I stop them ?

I've tried on several networks with completely different isp/router, this happens every time.

0

The S designation (as part of the UHS in your example) means that it is manually added to the routing table. Could be that these entries are in your /etc/iproute2/ files?
If that doesn't show anything, run a grep to find the files they exist in by:

grep -R "192.168.138.5" /etc

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.