5

IMPORTANT UPDATE: I tried to use the oldest VM I have, 275GB in size. As soon as I resize it to 500GB to make more space (it needs it), it will show the "Error loading operating system" now. What could cause this? Can I shrink it back?

-- Original --

We are running a Windows 2003 Server Standard in a VM because of a legacy software that we need to run (VMware ESXi, 6.5.0, 4564106). Lately, the server crashed (ESXi purple screen) and since then the machine doesn't boot anymore.

To solve the problem we restored a backup from a day earlier, but weirldy enough, the problem doesn't go away. Even when we go several days back, it still won't boot.

The problem in detail is the following: First, I get 'Error loading operating system' on booting. I can get it to a black cursor in the top left corner, that doesn't blink, by booting with the CD ISO and doing fixboot, fixmbr and bootcfg /rebuild. But I can't get it to boot properly. I tried the following:

  • Changing the disk controller in vsphere from SCSI to IDE, redoing the trinity (fixboot, fixmbr, bootcfg /rebuild)
  • I looked at the data using a debian live, everything is there. autoexec.bat and config.sys are empty (0 bytes), boot.ini is ok.
  • We tried to install Debian on a second disk, tried to boot with GRUB, same thing (black screen, white cursor, not blinking)
  • We tried more RAM, less RAM, fewer CPUs, more CPUs, using VM Version 10 (6.0), but no luck
  • Running it on another host
  • Running the Windows Server 2003 restore (where it overwrites over several system files), same result
  • Running chkdsk /P /R

I don't know anymore what else to try. I recently extended the VHD from 250GB to 500GB (and resized the partition to 500GB in compmgmt.msc), that's the only thing I did to it. The VHD used to be run in vmware Player before we converted it and ran it on vsphere.

Any ideas?

  • Try detaching any superfluous hardware from the virtual machine definition (eg: sound cards, USB controller, multiple PS2, etc). – shodanshok Sep 27 '17 at 15:05
  • Did, no improvement :( – LueTm Sep 27 '17 at 15:20
  • 1
    I have never seen the black screen with the cursor in a VM but I have seen it on a physical server. The fix, in that case, was the boot order was not correct. – SpiderIce Oct 2 '17 at 13:20
  • 1
    Option 2: would create a new VM server load a 2k3 os and do a full system restore from a working time. That would bypass any VM Bios issues too. – SpiderIce Oct 2 '17 at 13:41
  • 1
    Ah well, it was worth a shot. I fully understand your need to get your system back in service now by restoring into a fresh OS install. However, if you have time for post-mortem troubleshooting you might try fiddling with the BIOS settings with a fresh restore from backup - it's not impossible some of the previous troubleshooting steps might have "fixed" things in the wrong mode (EFI vs. BIOS). Good luck whichever way you go. – Brandon Xavier Oct 5 '17 at 12:03
0

I was able to boot it with Hiren's Boot CD. The server is now usable. I think the MBR and bootsector are currupt and I need to spend some time trying to fix it. But maybe I will just boot the machine with the CD a few times a year.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.