0

I have installed SQL server 2016 on windows 10. The install process completed successfully except for the final step, which was a restart. Prior to this I had tried a couple of times and the process did not seem to get as far.

I manually restarted the computer and opened SSMS. In the object explorer windows I clicked "Connect object explorer"->"Server name" drop down->"Browse for more"->local servers. But no instances showed.

I opened services and saw this

enter image description here

I tried starting each one but got the message

Windows could not start SQL server (SQLSERVEREXPRESS) service on local computer. Error 1067: The process terminated unexpectedly

What have i tried???

  • reviewed and tried the action suggested here but it points to an 8 year old post referencing .net 1,2 and 3
  • and here which has some stuff that I tried, detailed below
  • looked for something in the event viewer but MSSQLSERVER doesnt show in the event viewer snippet of where I would expect to find MSSQL
  • looked for an error log file here C:\Program Files\Microsoft SQL Server\MSSQL13.SQLEXPRESS but couldn't find one
  • followed advice from this youtube video (but I could not find the regedit entry he was referring to)
  • I noticed sql server browser wasn't running so I started that and then tried to run SQL server, this had the exact same error and imminently stopped sql server browser running.

Extra info

My system is a home computer and a fresh install of windows 10

Please help i'm out of ideas (I'd also be interested in how to get rid of those extra instances of SQL server I can see running in services)

Edit

This log file snippet was pulled from:

C:\Program Files\Microsoft SQL Server\130

however there is also a

  • C:\Program Files\Microsoft SQL Server\140
  • C:\Program Files\Microsoft SQL Server\110
  • C:\Program Files\Microsoft SQL Server\100
  • C:\Program Files\Microsoft SQL Server\90
  • C:\Program Files\Microsoft SQL Server\80

but 130 is the only one that contains \setup bootstrap\log (So I assume this is correct). Its a big file. I believe the below line may be of interest

(01) 2017-09-26 21:59:34 Slp: Error: Action "SqlEngineConfigAction_install_confignonrc_Cpu64" failed during execution.

0

After resolving several errors and seemingly going back to the first error I encountered I did the following:

  • removed all references to SQL server
  • turned off anti virus
  • turned off firewall
  • ran SQL server custom install (opting out of installing reporting services etc)

From here everything worked as expected.

I had initially had ignored the firewall warning you get during set up but tried reinstalling with the firewall switched off when it failed. The corruption must have happened on that first install and by not removing all references before trying again that corruption was persisted.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.