2

I am trying to install .NET 3.5 on a Windows Server 2016, through SCCM 2012, with the source file located on a remote network location, without mounting the ISO locally.

My .NET 3.5 installation keeps failing on a Windows Server 2016.

Running the usual
Install-WindowsFeature Net-Framework-Core -source \\Applications\Net35_2016\sxs

Fails with Error: 0x800f081f

Install-WindowsFeature : The request to add or remove features on the specified server failed.
Installation of one or more roles, role services, or features failed.
The source files could not be found.
Use the "Source" option to specify the location of the files that are required to restore the feature. For more
information on specifying a source location, see http://go.microsoft.com/fwlink/?LinkId=243077. Error: 0x800f081f

Of course, the files are definitely at that location. The feature installation fails both if run through powershell, or the install roles and features GUI.

I have tried running this command both locally and from the network location. The only way to make this work is to mount the ISO locally and then point to the ISO source as the source location.

This is only a workaround, because I need to be able to install .NET 3.5 from SCCM, where the source files are located remotely. I suppose it is an option to copy the ISO locally, mount it, install the feature, then un-mount it and delete it, but it's rather cumbersome and time consuming.

So my question is, how to install the feature with the sources located on a remote network location, without mounting the ISO locally?

Does anyone have any experience installing .NET 3.5 on Windows Server 2016 through SCCM remotely?

Thanks!

1

When ever i've run into that issue, it was related to WSUS. Even when using the CLI, it seems the server tries to pull .net 3.5 from WSUS. So, the one trick that I found to work around that issue, is to temporarily disable WSUS. in the WSUS hive (and if you're using group policy, that's the hive you want to modify), go to .\WindowsUpdate\AU In there, you'll find a string called "usewsusserver". Change it from 1 to 0, restart your windows update client, and try your install again. Presuming it works, do the reverse, set it back to 1, and then restart wsus again.

|improve this answer|||||
  • The full path to the key that worked for me was HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU – Dan Sinclair Jan 16 '19 at 15:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.