1

One of the websites we host through Flywheel was giving my team (we all work at the same location) this error:

This site can’t be reached

server DNS address could not be found.

ERR_NAME_NOT_RESOLVED

HOWEVER, the site WAS actually online and working fine. (Flywheel support confirmed this, https://isitdownorjust.me confirmed this, and when we got home and checked, we no longer encountered the error.)

What I can't figure out is what was causing it at work, though, because:

• My coworker checked from his phone, with wi-fi turned off, in private browsing mode and he was getting the same error (at our office). This eliminates the possibility of it being a caching issue at our router or location, correct?

• During my testing from the office, I cleared the host cache, flushed the DNS resolver cache, obviously cleared my browsing cache, renewed IP config via terminal command, and disabled all Chrome prediction.

Any idea why it still gave all of us this error, even though it was online? Especially for my coworker who turned wi-fi off and used incognito browsing to check from his phone…

  • 2
    So, are you suggesting everything is working fine now? Is there any reason to think that the DNS hosting your site wasn't temporarily down? This is a DNS issue so it doesn't necessarily have anything to do with Flywheel. Unless they are also hosting your domain records. – Appleoddity Sep 29 '17 at 14:16
  • My thought would be at least a single DNS server was having issues and so you were experiencing some temporary outages. Even if some queries worked elsewhere they could've Ben hitting a working DNS server. – Appleoddity Sep 29 '17 at 14:17
  • @Appleoddity the reason we don't think it was temporarily down (and the reason I mention Flywheel) is that they were able to confirm the site was online while we were still getting the error. isitdownorjust.me also confirmed it was online, while we were still getting the error. GoDaddy is hosting our domain records. We just point to Flywheel. Thanks for your response! That makes sense, a single DNS server while others were working. – flexlearn Sep 29 '17 at 14:53
  • 2
    You're conflating two different things. DNS not resolving the name has no bearing on whether or not the site is up and reachable. DNS not resolving the name means... well... that DNS couldn't resolve the name. Take a look at your DNS infrastructure. – joeqwerty Sep 29 '17 at 14:53
  • 1
    I can't find any reference to an outage in the last day (when did this problem occur?) - However, I did find an outage that affected GoDaddy DNS around a week ago. It was a problem with the backbone internet provider (Level 3). I mention that if Flywheel says the "site is up" it doesn't really mean diddily, because that doesn't mean your DNS infrastructure is up which is at GoDaddy. But as you say, it appeared up some places, so, intermittent and limited scope DNS issues would cause the results you obtained. – Appleoddity Sep 29 '17 at 15:04

protected by Community Dec 12 '17 at 9:16

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Browse other questions tagged or ask your own question.