3

Yesterday, I tried to upgrade my FreeNAS 9.10.2 system to FreeNAS 11. The upgrade failed to set the boot environment to FreeNAS 11, so I did that manually after seeing a reboot simply took me back to FreeNAS 9.10.2. That was a mistake: now it boots into what appears to be FreeNAS 11, but when I try to go to the web GUI, I simply get "Internal Server Error." I am able to SSH into the server, at which point I tried to trigger another upgrade by typing sudo freenas-update -v update. When I try this, here is what I get back:

[freenasOS.Configuration:692] TryGetNetworkFile(['http://update-master.ixsystems.com/FreeNAS/FreeNAS-9.10-STABLE/LATEST'])
[freenasOS.Configuration:822] TryGetNetworkFile(['http://update-master.ixsystems.com/FreeNAS/FreeNAS-9.10-STABLE/LATEST']):  Read 2360 bytes total
[freenasOS.Configuration:692] TryGetNetworkFile(['http://update-master.ixsystems.com/updates/ix_crl.pem'])
[freenasOS.Configuration:84] CheckFreeSpace(path=/tmp/tmpa9lojvfr.pem, pool=None, required=1028)
[freenasOS.Configuration:822] TryGetNetworkFile(['http://update-master.ixsystems.com/updates/ix_crl.pem']):  Read 1028 bytes total
[freenasOS.Update:977] Going to try checking cached manifest /var/db/system/update/MANIFEST
[freenasOS.Update:1001] Got this exception: [Errno 2] No such file or directory: '/var/db/system/update/MANIFEST'
[freenasOS.Configuration:692] TryGetNetworkFile(['http://update.ixsystems.com/FreeNAS/Validators/ValidateUpdate-dAn5lU.txt', 'http://update-master.ixsystems.com/FreeNAS/Validators/ValidateUpdate-dAn5lU.txt'])
[freenasOS.Configuration:84] CheckFreeSpace(path=/var/db/system/update/ValidateUpdate, pool=None, required=187)
[freenasOS.Configuration:822] TryGetNetworkFile(['http://update.ixsystems.com/FreeNAS/Validators/ValidateUpdate-dAn5lU.txt', 'http://update-master.ixsystems.com/FreeNAS/Validators/ValidateUpdate-dAn5lU.txt']):  Read 187 bytes total
[freenasOS.Update:1034] DownloadUpdate:  No update available
No updates available

Is there any way to force (from the command line) for the system to go through the FreeNAS 11 install process again so that it fill in whatever clearly didn't install properly in the previous version? If I can do it by SSH that would be idea -- the system is headless, so if I can take advantage of that SSH connection to repair the damage without starting from scratch, that'd be very helpful.

(I tried editing /boot/grub/grub.cfg to set default to the previous, FreeNAS 9.x entry so that the system would boot to the previous version, but that didn't seem to have an effect when I rebooted. Of course, that still wouldn't solve the improper FreeNAS 11 install anyway.)

3

After a few stories like that we stopped using FreeNAS and switched to plain vanilla FreeBSD + ZFS. I'd strongly suggest you to do the same.

  • I like that idea, but I really want more of an appliance type setup where I don't have to administer it via the command line when I want to just lightly fiddle with it. (I like having the option to use the command line, but especially for something on my home network, it is nice to have it pre-tuned to my basic needs.) – Timothy R. Butler Sep 30 '17 at 20:25
  • 1
    FreeNAS offers what you want, but only up to a point something goes belly up. – BaronSamedi1958 Oct 1 '17 at 10:34
  • Is there a good web based admin tool I could install on FreeBSD you'd suggest that would cover core remote administration? I'd love something that takes care of integrating user management with Samba, etc. – Timothy R. Butler Oct 2 '17 at 14:22
0

I figured out how to force the necessary upgrade. While the system was booting into FreeNAS 11, the failed upgrade had left the upgrade system thinking I was still on the FreeNAS 9.10.x "train." To switch trains while doing a command line upgrade, I used the following command sudo freenas-update -v -T FreeNAS-11-STABLE update.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.