4

we have like 10 servers (running as DC for each site), also some workstations/laptop working on each site. We use RDP to admin every DC server. This structure was working nice and well, BUT...

Today we have 2 servers (running Windows Server 2012 R2 full updated) that can't be accessed by RDP. We tried to diagnose the problem, this is the list of thing we checked:

  • Reboot the servers
  • Connect using mstsc and mstsc /admin using DNS name and IP
  • Check that Terminal Server service is up and running (we also restarted that service), also we disabled/enabled the service again.
  • Firewall is diabled
  • Ping is working OK, we have connectivity, we can access SMB shares for example...
  • HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\TerminalServer\WinStations\RDP-Tcp\PortNumber have 3389 value
  • We generated a new certificate for Remote Desktop (using Certificates mmc console)

But we can't connect to the servers using RDP. We checked again the remote servers:

  • RDP is not listening
  • netstat -an | findstr 3389 shows nothing
  • qwinsta dosn't show any RDP-TCP connection
  • There is no visible eventlog in EventViewer
  • chkdsk /R didn't solved the issue
  • sfc /scannow didn't solved the issue

This is the error we get after trying to RDP on that servers:

Can somebody help us with this issue? We tried every google-search-solution, without success

  • I know you checked the terminal services but did you check that the RDP settings are under system properties. I would disable RDP and reenable it not the service but the config. I would also check that no GPO or local security policy is messing up your RDP settings. Try using RSOP.msc I would also check the remote desktop services manager on the servers and the registry settings for RDP make sure everything is correct. – SpiderIce Oct 2 '17 at 15:01
0

So the 2 servers in question are Domain Controllers... Can you move the computer object from it's current location to the top level - OU=Computers

Then refresh group policy. Use rsop.msc to check before / after behaviour

As for re-configuring/installing the Remote Desktop Protocol (Terminal Server). I would try:

  • System Properties, Remote Tab, Don't allow
  • Backup and then delete registry key HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\TerminalServer
  • Reboot
  • Allow remote connections again. Check registry has re-created keys
Server Manager
  • Does it show remote desktop as enabled?
  • Any NIC teaming on these servers
  • Any multi ip addr
  • Any windows update driver changes to NIC

Do you have no output of these commands?

netstat -an -o | findstr 3389
TCP    0.0.0.0:3389           0.0.0.0:0              LISTENING       2144
TCP    192.168.9.35:3389      ??.??.???.???:50144    ESTABLISHED     2144
TCP    [::]:3389              [::]:0                 LISTENING       2144
UDP    0.0.0.0:3389           *:*                                    2144
UDP    [::]:3389              *:*                                    2144

and

netstat -an -b | findstr TermService
TermService
TermService
TermService 
TermService 
0

I had the same problem after a migrating a Windows Server 2008R2 (p2v), my resolution may work for you:

The problem occurs because the RDP service tries to use the old network adapter.

After some hours of google, I found this option in registry:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp

Change the LanAdapter value from 1 to 0, to allow RDP in all network adapters.

Reboot the system and test.

I hope it helps.

  • I edited the registry key to format it as code, that helps avoid copy/paste errors. Also the options, so they are clearer. You can use the backticks (`) or the code {} button in the editor. This removes format. – Leo May 21 '18 at 5:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.