On a Windows Server 2012 R2 machine, logged in as domain administrator trying to access the c:\users\public\desktop folder, getting access denied. This machine is the domain controller.

How can I get access to this folder?

  1. Using takeown from cmd.exe using runas as the local domain administrator:
C:\Users\Public>takeown /f c:\users\public\desktop
ERROR: Access is denied.
  1. Tried icacls
C:\Users\Public>icacls Desktop /t /grant Everyone:F
Desktop: Access is denied.
Successfully processed 0 files; Failed processing 1 files
  1. Viewing it via explorer when logged in as domain administrator

enter image description here

enter image description here

enter image description here

  • Is UAC enabled? Try turning it off if it is. – martin81 Oct 4 '17 at 19:42

Try to change owner of this folder to yourself and then you will be able to modify read/write permissions (for any user).

  • 1
    The OP already showed how they tried to do this - as covered in Point 1. – Anthony Geoghegan Oct 3 '17 at 21:24

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.