0

I'm setting up a test lab for using MDT at our organization and I've been having trouble getting the installs to run properly. So far I only have an older copy (5.2) of RealVNC working.

My installation for Adobe Reader DC along with two console programs we use (NETTERM and TinyTerm) seem to be failing. Acrobat and TinyTerm are using transformed MSI files, and for NETTERM its really just a folder copied over to the C: drive which I wrote a batch file for.

The Adobe installation has a very long log file with a lot of details that I've been pouring over this morning... logs for the other programs don't seem to be as abundant by default, but I imagine I'm having roughly the same issues for all three.

I pulled some snippets from the Adobe Log File in hopes that it might be useful to someone who is familiar with this kind of situation or has run into it before:

MSI (s) (80:78) [10:44:59:216]: Note: 1: 1311 2: \\WSUS\DeploymentShare$\Applications\Adobe Acrobat Reader DC\Data1.cab 
MSI (s) (80:78) [10:44:59:216]: Product: Adobe Acrobat Reader DC -- Error 1311.Source file not found(cabinet): \\WSUS\DeploymentShare$\Applications\Adobe Acrobat Reader DC\Data1.cab.  Verify that the file exists and that you can access it.

Error 1311.Source file not found(cabinet): \\WSUS\DeploymentShare$\Applications\Adobe Acrobat Reader DC\Data1.cab.  Verify that the file exists and that you can access it.
Property(S): AppsInUseSilentAbort = A process is running that cannot be shut down by Setup.  Please either close all applications and run Setup again, or restart your computer and run Setup again.
Property(S): AppsInUseUnknownAcrobatApps = Applications that are using Adobe Reader or Adobe Acrobat
Property(S): ERROR_CANNOT_OPTIMIZE_DISK = NOTE: Installation was successful. However, because your hard drive is fragmented, this application may not be able to launch as quickly as possible. To optimize performance, please defragment your hard drive and then repair this application under Add or Remove Programs in the Control Panel.

Property(S): ERROR_MIN_OVER_BIG = Setup has detected that you already have a more functional product installed.  Setup will now terminate.
Property(S): ErrorDialog = SetupError
Property(S): ISSCRIPT_VERSION_MISSING = The InstallScript engine is missing from this machine.  If available, please run ISScript.msi, or contact your support personnel for further assistance.
Property(S): IsMinIE_Message = requires Internet Explorer 7.0 or greater.  Please visit www.microsoft.com to upgrade Internet Explorer.
Property(S): KBDOCLINK_ERROR_INVDRIVE = http://kb2.adobe.com/cps/404/kb404946.html
Property(S): LC_UNSUPPORTED_OS = This application cannot be installed on this operating system. Setup will now terminate. Please refer to the minimum system requirements at http://www.adobe.com/go/reader_system_reqs.
Property(S): LC_UNSUPPORTED_OS_1 = This application cannot be installed on this operating system
Property(S): LC_UNSUPPORTED_OS_2 = Setup will now terminate. Please refer to the minimum system requirements at http://www.adobe.com/go/reader_system_reqs.
MSI (s) (80:78) [10:44:59:356]: Note: 1: 1708 
MSI (s) (80:78) [10:44:59:356]: Product: Adobe Acrobat Reader DC -- Installation operation failed.

MSI (s) (80:78) [10:44:59:356]: Windows Installer installed the product. Product Name: Adobe Acrobat Reader DC. Product Version: 15.007.20033. Product Language: 1033. Manufacturer: Adobe Systems Incorporated. Installation success or error status: 1603.

MSI (s) (80:78) [10:44:59:356]: Attempting to delete file C:\windows\Installer\1a554.mst
MSI (s) (80:78) [10:44:59:356]: Deferring clean up of packages/files, if any exist
MSI (s) (80:78) [10:44:59:356]: Attempting to delete file C:\windows\Installer\1a554.mst
MSI (s) (80:78) [10:44:59:356]: Unable to delete the file outside of the engine. LastError = 2
MSI (s) (80:78) [10:44:59:356]: MainEngineThread is returning 1603
MSI (s) (80:C8) [10:44:59:356]: No System Restore sequence number for this installation.

I can access the shares properly, these files run independently. So I'm not really sure what the problem is... and help would be greatly appreciated!

============UPDATE============

It turns out I had extracted my MSI originally using a How-To document that directed me to use 7zip, which didn't pull the cabinet file out.

Unfortunately I've corrected that issue and the application would still not install, I was going to update this with that log file, but I am currently going through the process of preparing the package from scratch.

I've extracted my EXE from the command line I've created and Admin Install from the MSI file I ran into problems patching the Admin Install MSI file with the MSP from the extracted EXE. I also tried a newer MSP from the Adobe Enterprise website. I get the following error:

 MSI (c) (50:F0) [11:19:55:484]: PATCH SEQUENCER: verifying the applicability of minor upgrade patch C:\Users\USER_FOLDER\Desktop\AcroRdrDC\admin\AcroRdrDCUpd1701220093.msp against product code: {AC76BA86-7AD7-1033-7B44-AC0F074E4100}, product version: 15.007.20033, product language 1033 and upgrade code: {A6EADE66-0000-0000-484E-7E8A45000000}
 MSI (c) (50:F0) [11:19:55:484]: PATCH SEQUENCER: minor upgrade patch C:\Users\USER_FOLDER\Desktop\AcroRdrDC\admin\AcroRdrDCUpd1701220093.msp is not applicable.

 MSI (c) (50:F0) [11:19:55:484]: Unknown\Absent: {AC76BA86-7AD7-0000-2550-AC110C4E7D00} - C:\Users\USER_FOLDER\Desktop\AcroRdrDC\admin\AcroRdrDCUpd1701220093.msp
 The upgrade cannot be installed by the Windows Installer service because the program to be upgraded may be missing, or the upgrade may update a different version of the program. Verify that the program to be upgraded exists on your computer and that you have the correct upgrade.
 C:\Users\USER_FOLDER\Desktop\AcroRdrDC\admin\full\AcroRead.msi

I'm planning on skipping the patch for now and just going to attempt to build my customization's from the Admin Install MSI and deploy that and see what sort of errors I get. However in the meantime if anyone has any input on the patch failure that would be greatly appreciated!

2

Setup errors typically don't lie: "Source file not found(cabinet): \\WSUS\DeploymentShare$\Applications\Adobe Acrobat Reader DC\Data1.cab. Verify that the file exists and that you can access it."

For further troubleshooting:
Choose NOT to capture the image in the MDT wizard upon first boot, so that you can still use the machine when the MDT process completes. When it's done, look in C:\Users\Administrators\AppData\Local\Temp\results.xml and/or C:\Users\Administrator\AppData\Local\Temp\SMSTSLog. You'll find any errors from MDT captured in one or both locations.

At that point, you can also open a Command Prompt as Administrator, do "net use \\wsus\DeploymentShare$", enter the username and password that you've been using, and manually run the install command from the share (the same command you set up in the app in MDT).

  • Mmmn, at first I thought perhaps that cabinet file was something that was supposed to be getting extracted into that directory during the installation, but someone in another forum suggested I run the equivalent of "AcroRdr20151500630033_MUI.exe -sfx_o"c:\temp\files" -sfx_ne" (obviously I have a newer file name) to extract the original exe instead of using 7zip, which I had done originally. Now I have a Data1.cab file. Unfortunately I can't patch the msi with the msp and I dropped that cab file into my MDT directory and the process still errors out. Will update OP with more details. – Sam K Oct 4 '17 at 12:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.