0

I have updated Apache2 on Debian Jesie using testing repository

https://www.shivering-isles.com/http-2-getting-ready-on-debian-with-apache2/

now i have:

Server version: Apache/2.4.27 (Debian)
Server built:   2017-09-23T22:08:01

an2mod http2 ..done

ls -la /etc/apache2/mods-enabled
lrwxrwxrwx 1 root root   28 Sep 25 16:42 http2.load -> ../mods-available/http2.load

/etc/apache2/conf-available/http2.conf .... edited

....

but checking https://www.tecnocroci.it HTTP2 doesn't work

  • did you restart apache? – Mike Oct 8 '17 at 10:08
  • Yes sure service apache restart – Augusto Murri Oct 8 '17 at 12:43
1

When I check the site in SSLLabs: https://www.ssllabs.com/ssltest/analyze.html?d=www.tecnocroci.it I see a few things:

  1. This site supports ALPN so you are using an up to date OpenSSL version as required by some browsers for HTTP/2. This is a common problem but doesn’t appear to be your problem.
  2. This site supports modern GCM ciphers as required by by some browsers for HTTP/2. This is a common problem but doesn’t appear to be your problem.
  3. The site does not support HTTP/2.

At this point all I can guess is one of two things:

  1. You’ve forgotten to include Protocols h2 http1.1 in your config as per the guide who’s link you included.
  2. You have something in front of your Apache (e.g. a load balancer or other infrastructure) which doesn’t support HTTP/2.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.