We have two new windows 2012 R2 servers that have been passed over to us we have a bit of an issue when trying to connect to these machines which I am unable to resolve.

The issue that we have encountered is that the new windows 2012 machines are prompting for credentials even AFTER the REP client has passed them through, this happens both when the credentials are entered manually and when they are stored in the client and passed through automatically.

Step 1 & 2: RDP Connection Dialog & credentials

Step 3: Enter them again once the session connects

This does not happen on any of our other machines, just the two newest ones.

Normally this wouldn't be a problem but we have an automated process which requires the RDP sessions to be connected to work - there are 25 RDP sessions needed on each server for this and entering the credentials 25 times is going to be a pain for whoever needs to maintain this going forwards.

Help/Advice appreciated.

  • After the first login, if you cancel the second it return to the desktop?
    – yagmoth555
    Oct 9, 2017 at 12:24
  • No, there is no way to cancel out of the second login other than disconnecting the session.
    – 5NRF
    Oct 9, 2017 at 12:59

2 Answers 2


There are 3 group policy settings to check:

Remember to do gpupdate /force and check the actual values with rsop.msc.

If nothing works, consider using alternative RDP client, whith better logon automation:

Also take a look at the following Windows Feedback Hub item: normal or for windows insiders and consider up-voting it. There's a tiny chance that this would help as well.

PS. Here's yet another similar issue.


Everything I tried from my researches didn't work!

I found the solution myself when I deleted the RDP connection (credentials and everything else) on my client machine and re-done it and voila! It worked like a charm!

It hopefully this will help somebody else.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .