0

This question already has an answer here:

On a computer with Windows 7 (virtualized PC on a server) I have a shared folder

\\czek000lbsv015\CHO\

Security is set to Authenticated Users can Read and execute, View folder content, Read.

Sharing is set to Read & Change for the domain user in question.

I have a problem when I try to run an image file by entering its UNC path to Run dialog, or doubleclicking the UNC link in Outlook or running C# Process.Start("\\czek000lbsv015\CHO\20171010153330_1BB5442.jpg").

\\czek000lbsv015\CHO\20171010153330_1BB5442.jpg               

it shows

windows photo viewer can't open this picture because either the picture is deleted, or it's in a location

But the file in a subfolder opens well when executed:

\\czek000lbsv015\CHO\THUMB\20171010153330_1BB5442.jpg               

When I click on either of the files in Explorer then both open well, I can browse the folder etc.

What is wrong, how to fix it? I need to open the file from a C# program.

marked as duplicate by Community Oct 27 '17 at 8:34

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • I found out that it was the case only for newly copied files to that folder, which preserved original permissions. – Vojtěch Dohnal Oct 24 '17 at 12:22
1

Change the share permisisons to Everyone Full. This will exclude it from being a possible cause.

Then change permissions to everyone read, then re-test and if still an issue reduce the permissions further.

It does sound like the permissions on the folder CH0 are different to the permissions on THUMB. Are the permissions not correctly applied as expected (can happen if you cancel a permissions change before it has completed).

  • I have reapplied security permissions on that folder and subfolders. I gave Authenticated Users right to Change and left sharing permissions on Read only. The problem went away. – Vojtěch Dohnal Oct 12 '17 at 11:20
  • I had to reapply inherited NTFS permissions again on all files... – Vojtěch Dohnal Oct 24 '17 at 12:06
  • The problem is that the newly copied files have wrong permissions somehow. – Vojtěch Dohnal Oct 24 '17 at 12:15
  • @Vojtech Dohnal There is no somehow about it! NTFS will always INHERIT permissions when COPYING folders/files, but RETAIN permissions when MOVING folders/files on the same drive. If you dont want the destination folder/files to have the same permissions, you must disable the inheritance and explicitly set the permissions on the parent folder you are copying/moving data to. – MikeC Nov 22 '17 at 8:44

Not the answer you're looking for? Browse other questions tagged or ask your own question.