I have a puzzle that I need help with.

We have two PLCs, each with a built-in webserver. They have been assigned IPs of and They talk to each other via Ethernet and are connected through a switch. The switch is also connected to a consumer-grade Asus router which connects to a cable modem. We have paid extra for a static IP.

If I connect a laptop to the router I can access either PLC by entering the IP in my browser. If I set up Port Forwarding to allow access to from the internet I can connect to the PLC from outside the network just fine. But if I change the Port Forwarding settings to access I get a “Server not responding” error.

I can’t understand why one works and the other doesn’t. Especially since they both work fine through the router.

Any thoughts?

  • 2
    Doesn't this question belong in SuperUser? Oct 13 '17 at 9:17
  • Try putting in the DMZ temporarily to eliminate any firewall issues in the router. That will help point you in the direction on what the problem is.
    – Dan
    Oct 13 '17 at 13:13
  • If you put PLC’s open for internet access, take appropiate security measures. Your PKC might become vunerable to hacking and DDOS attacks. See for example here. A good practice is to only allow access via a trusted VPN.
    – agtoever
    Oct 14 '17 at 4:56
  • Dan, I tried adding to the DMZ with no luck.
    – mmesford
    Oct 15 '17 at 5:19
  • agtoever, I’m only forwarding http traffic and there is no way to control processes remotely. A DDOS attack would be annoying but it wouldn’t affect our operations. Still, an interesting read, thanks.
    – mmesford
    Oct 15 '17 at 5:26

Seem like to me you forgot to add a default gateway in that PLC.

  • 1
    The system worked before we replaced the router. The old router was set up for a VPN connection. The new one is not. Wouldn’t the PLC need to have the correct Default Gateway for a VPN setup?
    – mmesford
    Oct 13 '17 at 5:36
  • 2
    @mmesford If the VPN give the remote user an local IP, no, that would still work even without the gateway, can you validate the setting in that PLC ?
    – yagmoth555
    Oct 13 '17 at 10:02
  • I haven’t been able to access the network configuration for the PLC. I’ll have to talk to tech support. Standby.
    – mmesford
    Oct 15 '17 at 5:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.