bandwidth = 0
base_persistdir = /var/lib/yum/repos/x86_64/6Server
baseurl = https://ordproxy.rhn.****.com/XMLRPC/GET-REQ/****-rhel-
cache = 0
cachedir = /var/cache/yum/*****-rhel-x86_64-server-6-ius
cost = 1000
enabled = 0

The ius repo is disabled already. But while giving yum update the following package showsup.

@server]#yum update
Loaded plugins: rhnplugin, security
This system is receiving updates from RHN Classic or RHN Satellite.
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package redis32u.x86_64 0:3.2.10-2.ius.el6 will be updated
---> Package redis32u.x86_64 0:3.2.11-1.ius.el6 will be an update
--> Finished Dependency Resolution

Dependencies Resolved

 Package                              Arch                               Version                                      Repository                                                      Size
 redis32u                             x86_64                             3.2.11-1.ius.el6                             *****-rhel-x86_64-server-6-ius                             515 k

Transaction Summary
Upgrade       1 Package(s)

Total download size: 515 k
Is this ok [y/N]:
  • Have you tried to run 'yum clean all' first? – Jaroslav Kucera Oct 13 '17 at 7:02
  • Tried yum clean all ... yum clean all metada – Renjan John Oct 13 '17 at 9:33
  • Is it possible you have the repo defined twice. Search for it in yum repo files in /etc/yum. repos.d/* – Jaroslav Kucera Oct 13 '17 at 9:35
  • yum repolist disabled | grep ius ius-archive IUS Community Packages for Enterprise Linux 6 - x8 ius-archive-debuginfo IUS Community Packages for Enterprise Linux 6 - x8 ius-archive-source IUS Community Packages for Enterprise Linux 6 - x8 ius-dev IUS Community Packages for Enterprise Linux 6 - x8 – Renjan John Oct 13 '17 at 9:41
  • # yum repolist enabled | grep ius *****-rhel-x86_64-server-6-ius ****** - RHEL (v. 6 for 64-bit x 10,054 – Renjan John Oct 13 '17 at 9:41

[****-rhel-x86_64-server-6-ius] looks an awful lot like a channel name in Satellite. If that is the case, disabling the repo in /etc/yum.repos.d/ius.repo won't help you. In fact, if you are using IUS as a Satellite channel then you should remove ius-release and any manually created IUS repo files in /etc/yum.repos.d to avoid exactly this confusion. You should ask your Satellite admin (hosting provider?) to disable the channel for you, or you can disable it locally (or just exclude certain packages) by adding appropriate yum directives to /etc/yum/pluginconf.d/rhnplugin.conf.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.