I have a ProLiant ML30 Gen9 server with an hardware raid adapter that I can configure using HP's "Smart Storage Administrator" (SSA) tool. I have defined my two 1TB drives to be in a RAID1 setup as a logical drive and enabled the primary boot on them.

However, if I start the CentOS7 installation, I can still select /dev/sda and /dev/sdb as installation medium, where I would expect only one (logical, mirrored, raid) drive.

update It is a Smart Array B140i. I have tried to load drivers, but they either lock up the install, cannot be loaded or do not return the array in the install. I spent an hour with HP support (which could only tell me to reset to defaults and get me links I already found).

What am I doing wrong?

  • Which RAID controller is in the system? – ewwhite Oct 13 '17 at 10:34
  • @ewwhite it is a Dynamic Smart Array B140i – Bart Friederichs Oct 13 '17 at 10:42

For the Dynamic Smart Array Controller, you will need to slipstream the proper driver disk into the CentOS 7 installer.

Please see page 10 of the installation manual for the RAID controller.

A device driver is required for the operating system to communicate with the disk drive controller. For more information on supported operating systems, see the product page for the appropriate controller on the Hewlett Packard Enterprise website (http://www.hpe.com/info/dynamicsa).

  • I really cannot find anything useful on the HP site. I tried the info from this question: serverfault.com/questions/721523/… But that didn't work, it says it cannot find a driver on the disk. – Bart Friederichs Oct 13 '17 at 12:29
  • As said in the update of my question, I tried quite some drivers, all of them don't work. – Bart Friederichs Oct 13 '17 at 14:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.