2

I started playing around with the Wiki feature of MacOS Server recently. I built out a really nice, simple wiki for my department and I love it. However, recently when I go to the list of Wikis and select the one I created for my area, the main page refuses to load.

However, if I navigate to one of the other pages using recent documents and then trace my way back through the links on the related list to what should be the main page, that page loads. This page is obviously the main wiki page because when I click the gear icon I am presented with a list of options, one of which is to delete the main page.

If I click the gear icon on the page that loads when I first open the wiki, I am not presented with that same "Delete the Main Page" option. It is like it is trying to load the wrong page whenever it goes to open the wiki. Any ideas on how I can fix this?

  • I've had some strange behavior like this when it often helped to simply switch off and on the wiki service. Have you tried that? – not2savvy Oct 13 '17 at 14:37
  • 1
    I gave it a try to see if that would fix it, but unfortunately it still seems to be messed up. I even tried turning the Wiki service off, rebooting the Mac, and then turning the Wiki service back on. – CorgiDev Oct 13 '17 at 16:02
0

I am not sure if there is a solution to the issue I was experiencing beyond what I ended up doing. I ended up creating a new wiki. Moved all the pages one by one over to the new one and deleted the old one. So far everything is working well. The connections between pages all switched to the new one as I moved everything over.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.