0

I have a file server running on a Windows Server 2012 R2 two-node cluster. The cluster role's real name is dept-server, as the university's central IT wants computer names in AD to be dept-xxxxx.

So the cluster role's FQDN is dept-server.dept.example.edu. I also want server.dept.example.edu to work as well, so I set an alias for the cluster. Works great, and I can access the shares via \dept-server as well as \server.

Here's where it gets frustrating: every morning when I wake up, I check my (2012 R2) DNS server, and for this alias name, there exist two new AAAA records...and the A record is deleted. I delete the AAAA records by hand and add the A record, and we're back in business. If the AAAA record lingers around and finds its way into workstations, I get the problems where \server doesn't work as expected.

This is quite simple; I need to do one of two things, preferably both:

  1. Tell the 2012 R2 clustered file server to stop registering AAAA records.
  2. Tell the 2012 R2 DNS servers to never, ever accept a registration from ipv6.

My DNS servers are internal for my department, forward to the campus BIND DNS servers, and are not authoritative on the campus domain.

Thoughts?

Thanks!

1

Sounds like "Register this connection's addresses in DNS" is enabled on your NICs. Based on my testing it looks like you can disable this just for INternet Protocol Version 6 under your NIC's Properties and keep the version 4 Register enabled if you want. I would disable the version 6 register with DNS on all NIC's for both cluster nodes.

  • I had unchecked "Register this connection's addresses in DNS" in IPv4 Properties. – user2007854 Oct 13 '17 at 21:40
  • I had unchecked "Register this connection's addresses in DNS" in IPv4 Properties. But then I had a revelation. IPv6 is unchecked. I temporarily checked it, double-clicked it, went to Advanced, and "Register this connection's addresses in DNS" is checked. I unchecked it, OKed out, then re-unchecked IPv6. Could this have been it? – user2007854 Oct 13 '17 at 21:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.