0

I need to connect to the office VPN from a linux machine. I'm able to connect to it only via Citrix NetScaler Gateway on Windows. The connection needs the secondary password (in my case is an OTP from Mobile Pass App) and I have all the client and ca certificates needed.

I've tried Cisco AnyConnect but I always get the following error message:

AnyConnect cannot confirm it is connected to your secure gateway. The local network may not be trustworthy. Please try another network.

I've also tried OpenConnect with which I always got:

XML response has no "auth" node

Other VPN clients like FortiClient does not support secondary password so I can't make them work and I can't find any solution for those errors. Is there a way to make one of them working or obtain a version of Citrix NetScaler Gateway compatible with Ubuntu?

1

There is indeed a Linux client. Even if maybe not as up to date as Linux or Mac client.

If you unpack the NetScaler firmware you have files like

nsgclient32.deb
nsgclient64.deb
nsginstaller[32|64].[deb|rpm]

I run the nsgclient64.deb package on an Ubuntu 14.04 and it works just fine for my needs. All you have to do is configure .citrix/userConfiguration.conf and then fire it up with NSGClient -c.

If you want you can also connect via the browser. But I prefer to have more control over it by using the cli.

| improve this answer | |
0

NetScaler Gateway full VPN requires a NetScaler Gateway client installed. There is no Linux version. Only Windows, Mac, IOS and Android. You can download them from the Citrix downloads site under NetScaler Gateway > Plugins & Clients and pick the version you want.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.