0

When starting my VM with windows server 2012 R2 which is my SQL-server, I get the following error: enter image description here

My SQL-server service won't run if I start it or if it gets started automaticly.

What I have done so far:

  • Ran C:\Program Files\Microsoft SQL Server\MSSQL11.MSSQLSERVER\MSSQL\Binn\sqlservr.exe, but there was nothing special in the errorlog.

  • Tried to start the service in the SQL Server Configuration Manager. I couldn't even open the application. I got an error: enter image description here

    • To solve this error I ran the following command in the cmd:

mofcomp "%programfiles(x86)%\Microsoft SQL Server\110\Shared\sqlmgmproviderxpsp2up.mof"

desc source

desc

The error above is what I got when I tried starting the SQL-server service. The logfiles in C:\Program Files\Microsoft SQL Server\MSSQL11.MSSQLSERVER\MSSQL\Log aren't that interesting. Except for the SQL Server Profiler log which is having red text: enter image description here

I wonder what I could do next. The WMI service is running.

| improve this question | | | | |
0

I went to the system windows logs in the event viewer: enter image description here

And I instantly knew what was wrong. I changed my password recently, because it expired. So I opened SQL Server Configuraton Manager and changed my password there as well: enter image description here

Again I tried starting the SQL-server service in the server manager and this time it started.

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.