2

Trying to connect to Samba shares on a Linux host with a Windows 10 client, even after setting the client Security Policy to allow non-NTLMv2 authentication, the client still gives errors like "The specified password is not correct." when using valid account credentials.

It sounds like most systems can support NTLMv2 authentication, so I'd like to just enable it on my Samba host and no longer worry about supporting the older protocols. It sounds like Samba defaults to having the NTLMv2 option, but, what parameters do I need to set to satisfy Windows (i.e. use NTLMv2 only)?

8

Supposedly, Samba's defaults match the following values, but I had to set them explicitly:

lanman auth = no
ntlm auth = yes
client lanman auth = no
  • Ran into the same issue using samba 4.8.5. Your solution still works. Thank you! – Lectrode Sep 26 '18 at 0:25
  • 4
    Upon further investigation, it looks like ntlm auth = ntlmv2-only is default. This will not work if Windows is set to NTVLM2 responses only to LM and NTLM - use NTLMV2 session security if negotiated. It will only work if Windows is set to Send NTLMv2 response only. Setting ntlm auth = yes allows NTLMv1 and above, which allows Windows to start with less secure protocol, but negotiate higher. – Lectrode Sep 28 '18 at 20:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.