0

trying to troubleshoot why jQuery isn't working after I change the domain in the Wordpress site URL. I'm getting these messages in the nginx debug log...

    2017/10/18 16:01:59 [info] 6657#6657: *495 epoll_wait() reported that client prematurely closed connection, so upstream connection is closed too while reading upstream, client: 221.234.103.135, server: example.com, request: "GET /wp-includes/js/wp-emoji-release.min.js?ver=4.8.2 HTTP/1.1", upstream: "fastcgi://unix:/var/run/php/php7.0-fpm.sock:", host: "example.com", referrer: "http://example.com/";
    2017/10/18 16:02:03 [info] 6657#6657: *498 epoll_wait() reported that client prematurely closed connection, so upstream connection is closed too (32: Broken pipe) while reading upstream, client: 221.234.103.135, server: example.com, request: "GET /wp-includes/js/jquery/jquery.js?ver=1.12.4 HTTP/1.1", upstream: "fastcgi://unix:/var/run/php/php7.0-fpm.sock:", host: "example.com", referrer: "http://example.com/";
    2017/10/18 16:02:03 [info] 6657#6657: *506 client 221.234.103.135 closed keepalive connection
    2017/10/18 16:02:04 [info] 6657#6657: *504 epoll_wait() reported that client prematurely closed connection, so upstream connection is closed too (32: Broken pipe) while reading upstream, client: 221.234.103.135, server: example.com, request: "GET /wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1 HTTP/1.1", upstream: "fastcgi://unix:/var/run/php/php7.0-fpm.sock:", host: "example.com", referrer: "http://example.com/";
    2017/10/18 16:02:04 [info] 6657#6657: *496 epoll_wait() reported that client prematurely closed connection, so upstream connection is closed too while reading upstream, client: 221.234.103.135, server: example.com, request: "GET /wp-includes/js/wp-embed.min.js?ver=4.8.2 HTTP/1.1", upstream: "fastcgi://unix:/var/run/php/php7.0-fpm.sock:", host: "example.com", referrer: "http://example.com/";
    2017/10/18 16:02:04 [info] 6657#6657: *507 client 221.234.103.135 closed keepalive connection

The only changes that were made to the configuration were the nginx server address and the Wordpress site URL. The site runs fine, but jQuery doesn't work.

Any ideas?

3
  • You should check the database and do a search and replace
    – Orphans
    Oct 19, 2017 at 9:07
  • thanks for the reply, check the db for what? what should i replace? There's a problem with enqueing the scripts. for some reason the js files aren't being served. the console shows errors.
    – Jim
    Oct 20, 2017 at 13:34
  • Do a databasedump, and do a search and replace of your old url to your new one.
    – Orphans
    Oct 21, 2017 at 18:49

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.