1

I had a CNAME configured with a GoDaddy account, we'll name it as cname.myCompany.com. cname the CNAME I named it as myCompany.com as my parent domain. myCompany.com has it's own SSL certificate.

cname (cname.myCompany.com) value points to www.compendiumblog.com (w/c it's own SSL certificate)

Now, when I do https://cname.myCompany.com - it loads the page but with broken SSL certificate.

I tried solving this with IIS (Server 2012R2) reverse proxy but it doesn't seem to work. I installed AAR and enabled Reverse Proxy.

From IIS, I created a new server farm named as blog.myCompany.com. Unchecked "Enable SSL offloading" in Routing Rules and from URL rewrite Inbound rule I set the action as ReWrite. Rewrite value as https://cname.myCompany.com/{R:0} and set a Server Variable as HTTP_X_COMPENDIUM_ID = e7dff869-c319-43c9-9bf1-eca9b46gb5de. Save the setting but it does not work.

How do I go with reverse proxying with IIS?

  • No worries.. I managed to work a solution. – Itchy Foot Oct 23 '17 at 14:00
  • may we have the chance to know your solution? – Max Dec 28 '17 at 13:19
0

Right click on your site name and select bindings.

You have to create an HTTPS binding per rewritten site

On ALL your HTTPS bindings , please check the "Require Server Name Indicaton" check box.

This will force IIS to check for a dns name input and will allow different certificates on other HTTPS bindings. without this settings , only one certificate is allowed per site.

Hope this will help someone

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.