0

I have an Asus RT-AC5300 running the latest stock firmware setup with WPA2 Entreprise. I can connect to the Wi-Fi with the radius server without any issue but I get disconnected every single hour. I set the network key rotation interval to 0 on all the WLAN interface (2.4, 5, and 5-2).

I logged in SSH to the router and typed the following command

nvram set wl_wpa_gtk_rekey=0
nvram set wl0_wpa_gtk_rekey=0
nvram set wl1_wpa_gtk_rekey=0
nvram set wl2_wpa_gtk_rekey=0
nvram commit service restart_wireless

I restarted my router, reset it, upgraded the firmware to the last version, used merlin, did the 30-30-30 thingy. Nothing worked. My users are disconnected every one hours or so. The Wi-Fi is still connected but they lose all the connections to the network, they can’t reach outside or contact any internal network service. They need to manually disconnect and reconnect for everything to work properly.

The problem disappears if I use WPA2 instead of WPA2 Entreprise… The entire network has the issue (Android, IOS, Windows 7, Windows 10 or OSX ).

Do you have any idea? I read a lot of documentation on the internet but nothing solved my issue.

  • I changed the type of connection to WPA Auto Entreprise with AES encryption and it solved the issue for Windows computers if they join the network using WPA Entreprise. They can also connect with WPA2 but will be disconnected after one hour. I still have the problem on both OSX and IOS with both settings. Any idea? – Ajite Nov 1 '17 at 0:05
0

could you try this:

nvram set wl1_pmk_cache=1440
nvram set wl1_net_reauth=86400
nvram commit
service restart_wireless

please replace "wl1" with the correct one.

BTW, why you need to set pmk_cache is because the net_reauth will be reset to pmk_cache * 60 when you restart the wireless.

Or you can just set wlX_pmk_cache=0 to disable the reauth.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.