0

I try to add pulseaudio-9.0-i586-1.xzm and firefox-56.0.1-i686-1.xzm modules to Porteus kiosk 3.7.0 32 bit. I need pulseaudio package, because starting from version 52 Firefox only produce sound via pulseaudio. When I try to run pulseaudio I get following error:

root@porteus-kiosk:~# pulseaudio
pulseaudio: error while loading shared libraries: libssl.so.1: cannot open shared object file: No such file or directory

Then I try to use Porteus USM package manager to install libssl.so.1

I run

sudo -i usm -s libssl.so.1 

and get:

Are you searching for a library file? 

libssl.so.1, it seems a library.
Would you like to find the package for it? [y/n]

libssl.so.1  was found in   firestorm-opensim-4.4.2.34167-i686-1_slonly.txz 

Package firestorm-opensim-4.4.2.34167-i686-1_slonly.txz is very big (about 50 MB). When I try to inject it in Porteus kiosk - Porteus kiosk hangs on boot.

How to find package for libssl.so.1?

0

Try installing openssl-solibs-1.0.2h-x86_64-1.txz.You may need to ln -s /lib64/libssl.so.1.0.0 to some other path.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.