23

Is there a way to disable the warning that is displayed in the notifications area, telling you that the Windows firewall is disabled?

Edit: We would specifically like to achieve this via group policy, not a manual process.

We disable the Domain firewall profile via GPO, which means Windows 10 machines constantly put warning notifications in the notification area about this. This generates user calls asking what the warning is about. We know it is disabled, so want to suppress the warning.

4 Answers 4

10

It's not possible to disable the firewall notifications alone, but since Windows 10 build 1607 it has been possible to disable all Security and Maintenance Notifications using

HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Notifications\Settings\Windows.SystemToast.SecurityAndMaintenance\Enabled = 0 (DWORD)

UPDATE: According to Ladislav Louka, the required value has changed to 1 since build 1809.

Either add this registry key directly via Group Policy or create a custom ADMX template for it. See Disabling Windows 10 Notifications via Group Policy by Jeffrey Harness.

I think any of these notifications equally doesn't need attention of a single user, but these settings must be monitored & maintained by the administrators, instead. The scope of this modification seems ok.

7
  • That's a shame. I assume by the fact you suggest a custom ADMX template, this setting does not currently exist in the downloadable Windows 10 templates? Oct 30, 2017 at 9:50
  • It seems so. I'd recommend creating the template suggested in the linked article if you have need for more of these settings. If you only need this one, simply add it as a direct registry update in your GPO. Oct 30, 2017 at 10:11
  • 1
    This didn't work for me on Windows 10. The registry setting was already set to 0.
    – MikeyE
    Apr 15, 2019 at 16:40
  • 2
    Tried it, it did not work. (July 2019)
    – Mike Nakis
    Jul 17, 2019 at 15:28
  • 5
    Follow up for anyone who tries this and it doesn't work. The DWORD value to disable notifications has for some reason been changed (I think in update 1809) to 1 May 4, 2020 at 14:57
12
  1. Click the Start button, type Security and Maintenance. (This should take you to Control Panel\All Control Panel Items\Security and Maintenance in the Control Panel.) You can also go directly to the control panel and get there that way.

  2. Choose Change Security and Maintenance settings.

  3. Uncheck Network firewall.

6
  • 1
    Sorry, I should have specified that I would also like to do this via Group Policy (I will go back and edit my question accordingly) Oct 27, 2017 at 15:57
  • I can see the "Report Problem - on" value, but I don't see a way to change it. Windows 10 Pro 1903. Jul 5, 2019 at 16:09
  • Found it under Windows Security => Firewall & network protection => Firewall Notification settings => Manage notifications => Scroll down to the bottom. Because that is obvious and not too buried. Thanks Microsoft! Jul 5, 2019 at 16:16
  • 3
    Tried it, it did not work. (July 2019.)
    – Mike Nakis
    Jul 17, 2019 at 15:29
  • Try the answer below by Yassine Imounachen; it works for me (April 2020).
    – Venryx
    Apr 7, 2020 at 11:06
9

Computer Configuration -> Administrative Templates -> Windows Components -> Windows Defender Security Center -> Notifications -> Hide all notifications

3
  • 6
    Works! However, the setting appears to have been moved slightly. I found it here: Edit group policy (start menu search) -> Computer Configuration -> Administrative Templates -> Windows Components -> Windows Security -> Notifications -> Hide all notifications
    – Venryx
    Apr 7, 2020 at 11:05
  • Doesn't work for me on Windows 1909. I still have the Windows Security - Action Needed icon in the tray.
    – richb
    Oct 7, 2020 at 3:53
  • tried all of the above, toast notification still popping up, then tried jedmon2 answer here reddit.com/r/sysadmin/comments/cexwbt/… and now it's gone for good
    – Ju Tutt
    Dec 26, 2020 at 10:38
9

I have spent 3 days testing this on 2 machines. When the following is in place the notifications do not pop up for the the firewall. When I remove them they comeback. I also tested inserting this into the default user hive so that all new users logging in will get the the registry change.

This is for Windows 10 1809.

[HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\CurrentVersion\PushNotifications]
"NoToastApplicationNotification"=dword:00000001
"NoToastApplicationNotificationOnLockScreen"=dword:00000001
1
  • 1
    Doesn't work for me on Windows 1909. I still have the Windows Security - Action Needed icon in the tray.
    – richb
    Oct 7, 2020 at 3:54

Not the answer you're looking for? Browse other questions tagged or ask your own question.