2

I can't seem to find anything about this online.

I've installed URL Rewrite via Web Platform Installer on Windows 10 running IIS 10, restarted IIS Manager, restarted IIS Server and also rebooted my machine but URL Rewrite option is still not available under Site -> IIS category.

I also found a post saying to check if rewrite.dll is available under C:\Windows\System32\inetsrv and it is.

I also tried reinstalling it, but can't seem to find a way to uninstall.

Any ideas as to why this is happening to me?

11

I found out that URL Rewrite can be uninstalled via Add or Remove Programs. Apparently its named IIS URL Rewrite Module 2 and not Microsoft URL Rewrite Module which a lot of posts suggest.

After uninstalling I installed it again via Web Platform Installer, restarted IIS Manager and now its available under IIS category.

Hope this helps some of you out there.

4
  • 1
    That seems like a broken installer; the same thing just happened to me; why did i have to install it twice to get it to work..weird Jun 27 '18 at 13:12
  • 1
    Same for me. After it didn't work with the first install, I had to uninstall via Add/Remove Programs and install again via Web Platform Installer. Thank you. Jul 24 '18 at 14:20
  • Simply clicking 'Repair' rather than doing a full reinstall was enough for me, I've had it happen twice now, think it may well be an installer bug. Feb 19 '19 at 13:11
  • Whatever was wrong seems to have been fixed. I only had to restart IIS Manager after installing the rewrite module once. Mar 9 '20 at 17:00
1

I have a bad feeling some of these technologies are being deprecated without mention. I was looking at IISNode as we have some apps that run on IIS, and it seemed like a good idea, but installing has been rough. URL Rewrite is needed for it, which led me here.

Searching Microsoft's site is getting tough, from the main link they didn't have IIS 10 and URL Rewrite. lol.

If you go here: https://www.iis.net/downloads/microsoft/url-rewrite there is an option to install the URL Rewrite via .MSI and not via the Web Platform Installer (second link, bottom of the page). They are up to a 2.1 version it looks like, although oddly when you install the MSI, the title page says "2" (no dot #).

I did have to exit the IIS manager and restart, but the URL rewrite showed right up. No registry hacks, didn't have to install it twice.

As with Homan Chu, I've had problems with the WPI on protected servers also, a stand alone .MSI is a lot easier. Hopefully the iis.net link will work for you!

0

I had similar issue on Windows Server 2016 IIS 10. Since I have no internet access on that server, I cannot use the webapi installer. I solved it by running the installer again and choose repair.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.