0

Windows Server 2016 environment, using RDS to publish sessions with desktops to users.

I want to apply specific proxy settings to IE-11 which is the browser which is standardly part of an RDS desktop on Win Server 2016.

These are set in a GPO object applied to the group of all RDS users, under
User Configuration > Preferences > Control Panel settings > Internet settings. Created a new IE-10 object, then set proxy address + port for http + https, and an exception list (overrides).

Applying GPO for gpudate /force, and it does apply as I can see from other settings.

However, on the proxy settings, the users have the exception list configured, but the proxy addresses are empty, both for http and https. Of course, that results in no proxy being used at all.

I have tried various other settings, and they seem to be applying but I cannot get the proxy address to stick at all.

Any ideas?

Update

In the registry, HKCU/Software/Microsoft/Windows/CurrentVersion/InternetSettings, both settings are there but if I change them, they don't change in IE. In the subkey Connections there are two values "DefaultConnectionSettings" and "SavedLegacySettings", and they both contain proxy address + overrides but IE-11 UI does not show proxy address and it does not apply it ...

0

Seems that there had been some prior messing-around in the registry.

After adding just an HTTP proxy in the GPP screen (that worked), then only an HTTPS proxy (again that worked), thereafter I was able to enter both http and https proxy and this time it did stick.

I do not have the possibility to verify that it will properly work on a clean server install. Probably it should.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.