1

Summary

When I try to install ESXi 5.5U3 on a DL360 G6, it fails because no storage is seen.

Details

Hardware

Server: HP Proliant DL360 G6

CPUs: 1 CPU, Intel Xeon E5506 @ 2.13GHz

RAM: 48GB RAM

Storage Adapter: P410i

Storage: 2x 1TB HP SATA drives

Storage config: RAID "10" on two drives, single 1TB "Logical Volume"

Install Process

ESXi compatibility for DL360 G6: https://www.vmware.com/resources/compatibility/detail.php?deviceCategory=server&productid=14664

ESXi source: HPE custom ESXi 5.5 U3 from https://my.vmware.com/web/vmware/details?downloadGroup=OEM-ESXI55U3B-HPE&productId=353

I'm booting using the ILO virtual media on an HTTP-provided ISO. This process works fine and I've had no issues with it on my local LAN. Here are some details about that generic boot process using the ILO CLI:

</>hpiLO-> power
power: server power is currently: Off
</>hpiLO-> cd /map1/oemhp_vm1/cddr1
</map1/oemhp_vm1/cddr1>hpiLO-> set oemhp_image=http://server.name.here/ESXHP55.iso
</map1/oemhp_vm1/cddr1>hpiLO-> set oemhp_boot=connect
</map1/oemhp_vm1/cddr1>hpiLO-> power on

After answering the usual VMware prompts, I eventually arrive at this screen and can go no farther:

Results of Booting ESXi ISO -- No Storage Found

I've tried wiping the RAID logical volume using DBAN, just in case any prior data on there was confusing ESXi, but that changed nothing. This also shows that the storage hardware works since I was able to see the storage using DBAN just fine.

The closest related question I found so far that would be similar to this was this question: ESXi 5.5 on HP ProLiant DL380 G7 Server. In that case, the admin wanted a JBOD disk pass-through, which isn't possible on the HP Proliant internal storage P410i controllers.

Normally I'd try loading a special HPE storage driver, but those are supposedly included on the HPE custom images. Anyone else running ESXi 5.5U3 on a DL360 G6 see this problem and get past it? Are there logs available somehow to show what's failing on the storage detection?

Thanks in advance for any help!

  • 2
    Please make sure you're using the correct HP installer image. – ewwhite Oct 29 '17 at 19:32
  • Confirmed-- I checked the MD5 of the final ISO sitting on the webserver used by the ILO vs. the VMware website provided MD5 just to be sure I didn't mess something up in the renaming process: MD5SUM (VMware): 078ca9ba36f617cd16f951f3919633bb $ md5sum ESXHP55.iso 078ca9ba36f617cd16f951f3919633bb ESXHP55.iso I know-- it seems like that HP installer should work, right? – Steve Bonds Oct 30 '17 at 17:22
  • Actually, you've given me an idea-- I'm going to try doing it "wrong" with the stock, non-HP VMware image just to see what happens. Nothing to lose, right? :-) – Steve Bonds Oct 30 '17 at 17:24
1

Try creating a small logical drive to install ESXi onto. I use a 16GB logical drive for this purpose. You can do this using the offline Array Configuration Utility.

Create a second logical drive for the remaining capacity for your actual VM data.

  • I didn't get around to trying this because the non-HP VMware image worked properly. – Steve Bonds Oct 30 '17 at 20:15
  • I ended up trying an install of the HP ESXi U3 onto an internal 16GB SD card. It installs fine, but doesn't see the RAID volume even after the install completes-- so it's not just an install-time issue. The HPE hardware health monitoring tools end up showing the RAID card, RAID volume, and underlying hard disks as present and healthy. This suggests no underlying issues aside from some oddness within ESXi itself. – Steve Bonds Jan 15 '18 at 23:48
0

The non-HP VMware image worked great. What the heck? I wasn't expecting that.

I grabbed ESXi 5.5.0U3 from https://my.vmware.com/web/vmware/details?productId=352&downloadGroup=ESXI55U3 (MD5: 279685120bdb867172dc1e0c7e93514e) and the storage configuration screen showed just what I'd expect:

Non-HP VMware image showing a single 931GB drive detected

I'm not sure what value HP is adding to those VMware images, but for Future Me or anyone else, it's worth trying the non-HP images if things don't seem to work with the HP images.

UPDATE: The HP 5.5 U2 image also works. Even though 5.5 U3 is on the compatibility list for a DL360 G6, it would appear that this release doesn't actually work properly.

The 5.5 U2 image name that works is VMware-ESXi-5.5.0-Update2-2403361-HP-550.9.2.40.2-Sep2015 (MD5: 4733f52e30e42549d0d16799002b5942)

  • For what it's worth, the HP 6.0U3 image worked great on a DL380 G7-- the HP RAID "Logical Volume" drives appear in the disk selection dialog just fine. – Steve Bonds Jan 11 '18 at 18:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.